aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-05-10 23:37:31 +0100
committerStuart Shelton <stuart@shelton.me>2016-05-10 23:37:31 +0100
commit1885e97c2c8834dd684b310487f01c9283e0d81f (patch)
tree4203fa39cbedc8c1f05055d90fe990d3b724e838 /app-admin
parentUpdate sys-apps/openrc-0.19.1 (diff)
downloadsrcshelton-1885e97c2c8834dd684b310487f01c9283e0d81f.tar.gz
srcshelton-1885e97c2c8834dd684b310487f01c9283e0d81f.tar.bz2
srcshelton-1885e97c2c8834dd684b310487f01c9283e0d81f.zip
Add app-admin/openrc-restart-crashed-1.0.0, update README.md
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/openrc-restart-crashed/Manifest3
-rw-r--r--app-admin/openrc-restart-crashed/files/openrc-restart-crashed.cron19
-rw-r--r--app-admin/openrc-restart-crashed/openrc-restart-crashed-1.0.0.ebuild29
3 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/openrc-restart-crashed/Manifest b/app-admin/openrc-restart-crashed/Manifest
new file mode 100644
index 00000000..51ce304b
--- /dev/null
+++ b/app-admin/openrc-restart-crashed/Manifest
@@ -0,0 +1,3 @@
+AUX openrc-restart-crashed.cron 402 SHA256 8da0ad29c919989dc9403b268c60819c53e189874cfda0d17d0dedf3eb7a9c90 SHA512 440cde30e23f46bdad97252fb022f06b162c63d2774961cb945721e683e3f38a738d095f53f4656d06db54c1e2aea7a9d507fc77eb279d5fbff1d62e52fe7d94 WHIRLPOOL d609b8dcf2360e58d824ce3a6263237cd0f5abffa588824d8793e51a69cf87b96909bda2d8d2bea51db58073f77670fa134482641810c086324867010dc73f8f
+DIST v1.0.0.tar.gz 8848 SHA256 edc6aad54d6dc28ba9d000ff4062cf1ec395274df63ec30b52cdb4bac09accbe SHA512 f04ea1b785f6abaf62719067f08136e6d5cdd77fe63cbc4c6db8814afb5f7609df3ebd34f0ef3ba8bdd62af1571ef1b1eae04cc2f0689bfc05bb1f3f2d9c5f7d WHIRLPOOL 3db185dc0ac95decaf0af86ff5a915356c425d7644c138c142a2e0e273d3759ca136d5043127dc280135ef60116d447ce2d31d321c71d711107c5b4ba87a256f
+EBUILD openrc-restart-crashed-1.0.0.ebuild 693 SHA256 eb95fc9cda615a2cba8dcd1b4cc1e2a644a5886c00c214c5fc0b0e17696e37cc SHA512 260c8f6b50523dfacf81dcb3cad25414f4c7744e916ec9d3a56ad4668db72a742d12d3d9f3d48639db65e08cfed3ca0f1997ef28caa2f3baf8c9a5d8c4eb7034 WHIRLPOOL f86c8d52e37de5755990f570bd82b4c0880a37873d829bd52593ffb71b50c6a6aa584b32a18de9643ffdd6f47ecde29ea64a3ff80a9bf1ae7d517f0e8389fdab
diff --git a/app-admin/openrc-restart-crashed/files/openrc-restart-crashed.cron b/app-admin/openrc-restart-crashed/files/openrc-restart-crashed.cron
new file mode 100644
index 00000000..c50a0a9e
--- /dev/null
+++ b/app-admin/openrc-restart-crashed/files/openrc-restart-crashed.cron
@@ -0,0 +1,19 @@
+# Global variables
+SHELL=/bin/sh
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
+
+# Local variables
+#services="monit"
+
+# Fields:
+# minute (0-59)
+# hour (0-23)
+# day of month (1-31)
+# month of year (1-12)
+# day of week (0-6, Sunday == 0)
+
+* * * * * root test -x /usr/local/sbin/openrc-restart-crashed && /usr/local/sbin/openrc-restart-crashed --quiet -- $services
+
+# vi: set nowrap:
diff --git a/app-admin/openrc-restart-crashed/openrc-restart-crashed-1.0.0.ebuild b/app-admin/openrc-restart-crashed/openrc-restart-crashed-1.0.0.ebuild
new file mode 100644
index 00000000..2a5dca44
--- /dev/null
+++ b/app-admin/openrc-restart-crashed/openrc-restart-crashed-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Report and optionally restart crashed OpenRC services"
+HOMEPAGE="https://github.com/srcshelton/openrc-restart-crashed"
+SRC_URI="https://github.com/srcshelton/openrc-restart-crashed/archive/v1.0.0.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="+cron"
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ sys-apps/openrc
+ cron? ( virtual/cron )"
+
+src_install() {
+ exeinto "/usr/local/sbin"
+ doexe "openrc-restart-crashed"
+
+ if use cron; then
+ insinto "/etc/cron.d"
+ newins "${FILESDIR}"/openrc-restart-crashed.cron openrc-restart-crashed
+ fi
+}