summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2020-03-08 13:44:56 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2020-03-08 13:44:56 -0500
commit0a8cf6765a0cb1d60896e69da1382a525234e3fa (patch)
tree6500cfd9b340b8cd28805fa6808a06a35f267b63 /app-backup
parentImport latest vmware-{modules,workstation} from stefantalpalaru-overlay (diff)
downloadsattvik-0a8cf6765a0cb1d60896e69da1382a525234e3fa.tar.gz
sattvik-0a8cf6765a0cb1d60896e69da1382a525234e3fa.tar.bz2
sattvik-0a8cf6765a0cb1d60896e69da1382a525234e3fa.zip
Update duplicity ebuild
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest3
-rw-r--r--app-backup/duplicity/duplicity-0.8.11.1596.ebuild53
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch21
3 files changed, 77 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index 9efc0c6..6e8eeb3 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,4 +1,7 @@
AUX duplicity-0.8.09-fix-docs.patch 549 BLAKE2B 57e20c1f65918e548941ce56969a9a22620bb69577ca1c0168149f28203f0d1068fd6676ade5ef153069823070e033791b4a4e517e79a11d9b33a30f6444c174 SHA512 0ba8e5f02e5e873835ac418d312694ea6b699fc15a2b09828aaa0e2b75bb499d0b054799c619d1bd8bafc97e042eb12e6a64a3c0298158cbc7c2dcd30216f4a2
+AUX duplicity-0.8.11.1596-fix-docs.patch 665 BLAKE2B f664af2867546957fafdf717b792ebc8e4d75fdd6451d7c252284107f8fcd4029d2815ffa21c622738226885e396b25a1f2485f44a15275e0a8b0b248ea27735 SHA512 4ce3d557c5ef3e32f9032cc10285b8059800b8d0f57e46ebcb0fc85a1da361b0475303ba94f8e4a25a70cb27b506de477d7657fbfe0b77d80646a3025bcd8bb2
DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
+DIST duplicity-0.8.11.1596.tar.gz 1872223 BLAKE2B ad3ee2536731d1a6e8fb3fd87bb69b8ce8b43bb90688fe957cfb2718ad44f57db98c3aec4805356a7d44bea681f6ec9603aa082dbf86e58684fbe8000d1676b5 SHA512 67940d73d8213559ba88ec21e1326aca0dd065888cbf2e3c68f0f515ba9246100fd6e6d0bd1f12cb678702559f2266b7905931506d2ff6fe6fd35c673593479b
EBUILD duplicity-0.8.09-r1.ebuild 1225 BLAKE2B 1260fcdada29a0ff8129b8152698838a6f69be3dc110f6c5b84ee9ee32ffe5666ea351a740322e4c36b9a0acacb6c23ade0ae0b3d2207f0a463f644610c88294 SHA512 2901dc23c8f56934ce9c3e6fb68a40a68124a26919b3ee9b3699955500527b2f21698fe003f86c133d29a6c0c76c6920c9d157f381adaab4d648fd7383da0f56
+EBUILD duplicity-0.8.11.1596.ebuild 1199 BLAKE2B eb1f6feb456a2517cbd1ded57a2d8bdd72f81e0fa03eb556d6a38c23f0a0dc1f5f5e951e134ebe7f191e693d9006f8d4db0cbb975421120bb8c637cea8073e9c SHA512 5badfc25fe4f8893a5fe6fe0a87819b6112a105cec932b393322605aedb74a2e492a82545726e2a983e0b42b527a91a6b957aa669f17d7932685b9622abfa039
MISC metadata.xml 1464 BLAKE2B ce583c0e3d2a4b51e8c7afdecd6032bee99fdbbd1a435772587812b1cf87275f9f00d73b7bd6b7f0b7992d2947058e40a1b37fcd775e1c0902e81ebb55d92390 SHA512 bbeb13d7d9728e930eaf2f40fc03ef75234e3c27e532e5e1d069e8da44a0ddfe1b406c53588413a83985b03c94207c8ce1739ccf60e8d114abfde817375ea0fc
diff --git a/app-backup/duplicity/duplicity-0.8.11.1596.ebuild b/app-backup/duplicity/duplicity-0.8.11.1596.ebuild
new file mode 100644
index 0000000..dba5810
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.11.1596.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( || (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ ) )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch b/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch
new file mode 100644
index 0000000..6b8c710
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.11.1596-fix-docs.patch
@@ -0,0 +1,21 @@
+--- duplicity-0.8.11.1596/setup.py 2020-03-05 09:18:42.532941503 -0500
++++ duplicity-0.8.11.1596/setup.py 2020-03-05 09:20:10.612061492 -0500
+@@ -88,18 +88,6 @@
+ u'bin/rdiffdir.1'
+ ]
+ ),
+- (u'share/doc/duplicity-%s' % version_string,
+- [
+- u'AUTHORS',
+- u'CHANGELOG',
+- u'Changelog.GNU',
+- u'COPYING',
+- u'README',
+- u'README-LOG',
+- u'README-REPO',
+- u'README-TESTING',
+- ],
+- ),
+ ]
+
+ if not os.environ.get(u'READTHEDOCS') == u'True':