aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-9999.ebuild')
-rw-r--r--www-client/firefox/firefox-9999.ebuild36
1 files changed, 1 insertions, 35 deletions
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index c98d64f..387137d 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -4,43 +4,9 @@
EAPI="3"
-inherit mozilla-scm mozilla-config pax-utils
+inherit mozilla-app
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/en-US/firefox"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-src_prepare() {
- # tmp fix
- sed -i \
- -e '/XPIDL_LINK =/s|$(LIBXUL_DIST)/sdk/bin|$(DEPTH)/xpcom/typelib/xpt/tools|' \
- config/config.mk \
- js/src/config/config.mk \
- || die "tmp fix failed (maybe the time to remove it)"
-
- # Gentoo install dirs
- sed -i \
- -e 's:$(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):$(includedir)/idl:' \
- -e 's:$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):firefox:' \
- -e 's:$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION):firefox:' \
- config/autoconf.mk.in \
- || die "${MAJ_XUL_PV} sed failed!"
-
- eautoreconf
-}
-
-src_configure() {
- mozconfig_configure
-}
-
-src_install() {
- mozilla-scm_src_install
- mozilla_application_install
-
- pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/firefox
-
- # Plugins dir
- dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
- || die "failed to symlink"
-}