aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/nspr/files/libs.patch')
-rw-r--r--dev-libs/nspr/files/libs.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/nspr/files/libs.patch b/dev-libs/nspr/files/libs.patch
deleted file mode 100644
index 2266ee5..0000000
--- a/dev-libs/nspr/files/libs.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- mozilla/nsprpub/lib/libc/src/Makefile.in.orig 2005-06-01 14:28:26.000000000 +0000
-+++ mozilla/nsprpub/lib/libc/src/Makefile.in 2006-01-15 02:50:39.000000000 +0000
-@@ -112,6 +112,10 @@
- MKSHLIB += -R '$$ORIGIN'
- endif
-
-+ifeq ($(OS_ARCH), Linux)
-+DSO_LDOPTS +=-Wl,-R,'$$ORIGIN'
-+endif
-+
- ifeq ($(OS_ARCH),OS2)
- MAPFILE = $(OBJDIR)/$(LIBRARY_NAME)$(LIBRARY_VERSION).def
- GARBAGE += $(MAPFILE)
---- mozilla/nsprpub/lib/ds/Makefile.in.orig 2005-06-01 14:28:25.000000000 +0000
-+++ mozilla/nsprpub/lib/ds/Makefile.in 2006-01-15 02:52:30.000000000 +0000
-@@ -102,6 +102,10 @@
- MKSHLIB += -R '$$ORIGIN'
- endif
-
-+ifeq ($(OS_ARCH), Linux)
-+DSO_LDOPTS += -Wl,-R,'$$ORIGIN'
-+endif
-+
- ifeq ($(OS_ARCH),OS2)
- MAPFILE = $(OBJDIR)/$(LIBRARY_NAME)$(LIBRARY_VERSION).def
- GARBAGE += $(MAPFILE)
---- mozilla/nsprpub/pr/src/Makefile.in.orig 2005-06-01 14:28:27.000000000 +0000
-+++ mozilla/nsprpub/pr/src/Makefile.in 2006-01-15 03:29:36.000000000 +0000
-@@ -168,6 +168,7 @@
- else
- OS_LIBS = -ldl
- endif
-+DSO_LDOPTS +=-Wl,-R,'$$ORIGIN'
- endif
-
- ifeq ($(OS_ARCH),HP-UX)
---- mozilla/nsprpub/config/nspr-config.in.orig 2005-05-11 00:53:41.000000000 +0000
-+++ mozilla/nsprpub/config/nspr-config.in 2006-01-15 06:37:58.000000000 +0000
-@@ -122,7 +122,7 @@
- fi
-
- if test "$echo_libs" = "yes"; then
-- libdirs=-L$libdir
-+ libdirs="-Wl,-R$libdir -L$libdir"
- if test -n "$lib_plds"; then
- libdirs="$libdirs -lplds${major_version}"
- fi
---- mozilla/nsprpub/configure.orig 2006-01-14 22:41:37.000000000 +0000
-+++ mozilla/nsprpub/configure 2006-01-14 22:49:14.000000000 +0000
-@@ -3893,7 +3893,7 @@
- PR_MD_CSRCS=linux.c
- MKSHLIB='$(CC) $(DSO_LDOPTS) -o $@'
- DSO_CFLAGS=-fPIC
-- DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@)'
-+ DSO_LDOPTS='-shared -Wl,-soname -Wl,$(notdir $@).$(MOD_MINOR_VERSION)'
- _OPTIMIZE_FLAGS=-O2
- _DEBUG_FLAGS="-g -fno-inline" # most people on linux use gcc/gdb, and that
- # combo is not yet good at debugging inlined