aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-04-25 12:54:03 +0200
committerSardem FF7 <sardemff7.pub@gmail.com>2011-04-25 12:54:03 +0200
commit526618bf907ff8484e206826918cf40ceb798978 (patch)
tree3b2ca1f9a5ede1632e1060f5d726886f9d88c1e0
parentFixed upstream (diff)
downloadsardemff7-526618bf907ff8484e206826918cf40ceb798978.tar.gz
sardemff7-526618bf907ff8484e206826918cf40ceb798978.tar.bz2
sardemff7-526618bf907ff8484e206826918cf40ceb798978.zip
Add i3bar
-rw-r--r--x11-plugins/i3bar/Manifest1
-rw-r--r--x11-plugins/i3bar/i3bar-9999.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-plugins/i3bar/Manifest b/x11-plugins/i3bar/Manifest
new file mode 100644
index 0000000..26afe54
--- /dev/null
+++ b/x11-plugins/i3bar/Manifest
@@ -0,0 +1 @@
+EBUILD i3bar-9999.ebuild 1095 RMD160 bb3f6f2805650a781f3d9369c7d551b5ca1c8c46 SHA1 4e0a616d311f214394a04033951cd7f05160ffe8 SHA256 ae22b1b517efa0c03b78001fea56db7d8623b84eb95dd002be290db7f4509255
diff --git a/x11-plugins/i3bar/i3bar-9999.ebuild b/x11-plugins/i3bar/i3bar-9999.ebuild
new file mode 100644
index 0000000..59684ff
--- /dev/null
+++ b/x11-plugins/i3bar/i3bar-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://git.merovius.de/i3bar"
+: ${EGIT_BRANCH:=tree}
+
+inherit base multilib git-2
+
+DESCRIPTION="An xcb-based status- and ws-bar for i3"
+HOMEPAGE="http://i3.zekjur.net/tree/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug +man"
+
+RDEPEND="
+ >=x11-libs/libxcb-1.1.93
+ >=x11-libs/xcb-util-0.3.3
+ || (
+ <x11-libs/xcb-util-0.3.8
+ (
+ >=x11-libs/xcb-util-0.3.8
+ >=x11-libs/xcb-util-keysyms-0.3.8
+ >=x11-libs/xcb-util-wm-0.3.8
+ )
+ )
+ x11-libs/libX11
+ dev-libs/libev
+ dev-libs/yajl
+ "
+DEPEND="${RDEPEND}
+ >=x11-proto/xcb-proto-1.3
+ man? (
+ >=app-text/asciidoc-8.3
+ app-text/xmlto
+ )
+ "
+
+src_prepare() {
+ use debug || { sed -i -e "s:DEBUG=1:DEBUG=0:" common.mk || die "sed die - debug" ; }
+}
+
+src_compile() {
+ emake || die "emake compile die"
+ use man && { emake -C doc || die "emake man die" ; }
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die "emake install die"
+ use man && { doman doc/*.1 || die "doman die" ; }
+}