summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/aget/aget-0.4.1.ebuild')
-rw-r--r--net-misc/aget/aget-0.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/aget/aget-0.4.1.ebuild b/net-misc/aget/aget-0.4.1.ebuild
new file mode 100644
index 0000000..51ada0b
--- /dev/null
+++ b/net-misc/aget/aget-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/aget-0.4.ebuild,v 1.14 2010/01/07 15:45:03 fauli Exp $
+
+inherit eutils
+
+#DEB_PATCH="${PN}_${PV}-4.diff"
+DESCRIPTION="multithreaded HTTP download accelerator"
+HOMEPAGE="http://www.enderunix.org/aget/"
+SRC_URI="http://www.enderunix.org/${PN}/${P}.tar.gz"
+# mirror://debian/pool/main/a/${PN}/${DEB_PATCH}.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# epatch "${WORKDIR}"/${DEB_PATCH}
+ sed -i \
+ -e '/^CFLAGS/s:=.*:+= -Wall $(CPPFLAGS):' \
+ -e '/^LDFLAGS/s:=:+=:' \
+ Makefile
+ sed -i '/_XOPEN_SOURCE/d' Head.c
+}
+
+src_install() {
+ dobin aget || die
+ dodoc AUTHORS ChangeLog README* THANKS TODO
+ doman debian/aget.1
+}