summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
committerroot <root@SCU-MED-DSK-47.datys.cu>2010-03-18 18:56:03 -0400
commit1f215b8bd262f88d0a1629bc10c1acd5ec77e864 (patch)
treef2aff1a884c8d3d5f035e64fa9b3d6f058d15632 /gnome-extra
downloadrubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.gz
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.tar.bz2
rubenqba-1f215b8bd262f88d0a1629bc10c1acd5ec77e864.zip
Initial commit
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-rss/Manifest4
-rw-r--r--gnome-extra/evolution-rss/evolution-rss-0.1.4-r1.ebuild56
-rw-r--r--gnome-extra/evolution-rss/files/0.1.4-configure.patch11
-rw-r--r--gnome-extra/evolution-rss/files/0.1.4-make-install.patch30
4 files changed, 101 insertions, 0 deletions
diff --git a/gnome-extra/evolution-rss/Manifest b/gnome-extra/evolution-rss/Manifest
new file mode 100644
index 0000000..ea7b352
--- /dev/null
+++ b/gnome-extra/evolution-rss/Manifest
@@ -0,0 +1,4 @@
+AUX 0.1.4-configure.patch 325 RMD160 2e255a472e1d349b76f2ff6a9b0beef4ebfc5c71 SHA1 7e2ebcee98bb91e73a7991a682fbc10982308704 SHA256 46c00d96d00c91a2a0c4d97d5a40fab063b53966cbe4a42982458b03370a6dec
+AUX 0.1.4-make-install.patch 1335 RMD160 3bb9a8c86dff7e8054123cb435a13febe89d3b10 SHA1 b5f73a2d32b7548951b4965e205dad0c9b753357 SHA256 1cf115943e598f41e2278f5c41396e74949e6f0b3d770d61d53c862da92245bf
+DIST evolution-rss-0.1.4.tar.gz 618558 RMD160 afeef42be9e4b593e98d9c2055da857deb99d0ae SHA1 0bea56f2004423c6506d6ff551202eda23ad840c SHA256 dd640e0574ca78efeafcc53b7e912496dd018f47c6ca93df8f051b0080489a14
+EBUILD evolution-rss-0.1.4-r1.ebuild 1311 RMD160 74fe8e00223190cda033c7800e6cb4aa46d88dd5 SHA1 2ac0ed8bead69af313815f49cdc2d74914552641 SHA256 09aa86e831c8bc905e060a367006f9ac43706c024f044691d709023efc39a0b4
diff --git a/gnome-extra/evolution-rss/evolution-rss-0.1.4-r1.ebuild b/gnome-extra/evolution-rss/evolution-rss-0.1.4-r1.ebuild
new file mode 100644
index 0000000..6db7974
--- /dev/null
+++ b/gnome-extra/evolution-rss/evolution-rss-0.1.4-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="An RSS reader plugin for Evolution"
+HOMEPAGE="http://gnome.eu.org/index.php/Evolution_RSS_Reader_Plugin"
+SRC_URI="http://gnome.eu.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus +webkit xulrunner"
+
+RDEPEND=">=mail-client/evolution-2.24
+ >=gnome-base/gconf-2
+ net-libs/libsoup:2.4
+ >=dev-libs/glib-2.16.2:2
+ >=gnome-base/libglade-2
+ >=gnome-extra/gtkhtml-3.18.3:3.14
+ >=x11-libs/gtk+-2.12:2
+ >=gnome-extra/evolution-data-server-1.2
+ xulrunner? ( || (
+ net-libs/xulrunner:1.9
+ www-client/seamonkey
+ www-client/mozilla-firefox ) )
+ dbus? ( dev-libs/dbus-glib )
+ webkit? ( net-libs/webkit-gtk )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+DOCS="AUTHORS ChangeLog FAQ NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable dbus)
+ $(use_enable webkit)
+ $(use_enable xulrunner gecko)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix dbus configure flag switch
+ epatch "${FILESDIR}"/${PV}-configure.patch
+
+ # Fix rules causing sandbox violations
+ epatch "${FILESDIR}/"${PV}-make-install.patch
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
diff --git a/gnome-extra/evolution-rss/files/0.1.4-configure.patch b/gnome-extra/evolution-rss/files/0.1.4-configure.patch
new file mode 100644
index 0000000..d2aea11
--- /dev/null
+++ b/gnome-extra/evolution-rss/files/0.1.4-configure.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2009-08-25 14:13:05.000000000 +0200
++++ b/configure.ac 2009-08-30 11:00:42.000000000 +0200
+@@ -267,7 +267,7 @@
+ dnl D-BUS stuff
+ dnl ***********
+ have_dbus=no
+-AC_ARG_ENABLE([DBUS],
++AC_ARG_ENABLE([dbus],
+ AS_HELP_STRING([--disable-dbus],[Disable D-BUS support (default: enabled)]),
+ [])
+
diff --git a/gnome-extra/evolution-rss/files/0.1.4-make-install.patch b/gnome-extra/evolution-rss/files/0.1.4-make-install.patch
new file mode 100644
index 0000000..9eed2a9
--- /dev/null
+++ b/gnome-extra/evolution-rss/files/0.1.4-make-install.patch
@@ -0,0 +1,30 @@
+# Remove invalid commands triggering sandbox issues.
+--- a/src/Makefile.am 2009-09-13 18:56:14.751948079 +0200
++++ b/src/Makefile.am 2009-09-13 18:56:55.000000000 +0200
+@@ -107,26 +107,6 @@
+ @INTLTOOL_SERVER_RULE@
+ @INTLTOOL_SCHEMAS_RULE@
+
+-install-data-local:
+- rm -f $(PLUGIN_INSTALL_DIR)/*gnome-cooly*
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
+-
+-uninstall-local:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-uninstall-rule $(schema_DATA)
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/remove_folder
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/pass_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/startup_check
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/rep_check
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/rep_check_timeout
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/auth_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/host_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/html_render
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/use_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/user_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/port_proxy
+- $(GCONFTOOL) -u /apps/evolution/evolution-rss/display_summary
+-
+-
+ DISTCLEANFILES = $(schema_DATA)
+
+ glade_DATA = \