summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-02 17:40:33 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-02 17:40:33 -0400
commitb3f6bdefa286fd0b6a9d13e8b880773c15a68963 (patch)
tree14d1bcab51aec2336bd8d9f7b44c2d5d41cd976a
parent20100702 - Cambio automático (diff)
downloadrubenqba-b3f6bdefa286fd0b6a9d13e8b880773c15a68963.tar.gz
rubenqba-b3f6bdefa286fd0b6a9d13e8b880773c15a68963.tar.bz2
rubenqba-b3f6bdefa286fd0b6a9d13e8b880773c15a68963.zip
20100702 - Cambio automático
-rw-r--r--dev-libs/xsdefinitions/Manifest2
-rw-r--r--dev-libs/xsdefinitions/xsdefinitions-1.5.0.3576.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-libs/xsdefinitions/Manifest b/dev-libs/xsdefinitions/Manifest
new file mode 100644
index 0000000..3d3ed10
--- /dev/null
+++ b/dev-libs/xsdefinitions/Manifest
@@ -0,0 +1,2 @@
+DIST xsdefinitions-1.5.0.3576.tar.bz2 228205 RMD160 13fa4a7cc61ab448824d6952c4560d1331b83c4d SHA1 0f202e243cfa87103f8aa65e706e2605099670e6 SHA256 1b13ffe4474d97fa203171342e400239413e04ad8d7d7f3565943db5a7a41761
+EBUILD xsdefinitions-1.5.0.3576.ebuild 3307 RMD160 33e543b2cae1c0fa5e333003d5a5521502b6ecb4 SHA1 47719e0fb0770d1b3cd3ff1e973741ee2ebb7d53 SHA256 be23f62645f0de6a953907c09d2b47b2dbb5c3d462b43c3492f2e4ef470bfd24
diff --git a/dev-libs/xsdefinitions/xsdefinitions-1.5.0.3576.ebuild b/dev-libs/xsdefinitions/xsdefinitions-1.5.0.3576.ebuild
new file mode 100644
index 0000000..d8ec5d9
--- /dev/null
+++ b/dev-libs/xsdefinitions/xsdefinitions-1.5.0.3576.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+# The EAPI variable tells the ebuild format in use.
+# Defaults to 0 if not specified. The current PMS draft contains details on
+# a proposed EAPI=0 definition but is not finalized yet.
+# Eclasses will test for this variable if they need to use EAPI > 0 features.
+#EAPI=0
+
+# inherit lists eclasses to inherit functions from. Almost all ebuilds should
+# inherit eutils, as a large amount of important functionality has been
+# moved there. For example, the epatch call mentioned below wont work
+# without the following line:
+inherit eutils
+# A well-used example of an eclass function that needs eutils is epatch. If
+# your source needs patches applied, it's suggested to put your patch in the
+# 'files' directory and use:
+#
+# epatch "${FILESDIR}"/patch-name-here
+#
+# eclasses tend to list descriptions of how to use their functions properly.
+# take a look at /usr/portage/eclasses/ for more examples.
+
+# Short one-line description of this package.
+DESCRIPTION="This is a sample skeleton ebuild file"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://foo.bar.com/"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="http://172.16.157.60/ruben/noti/xsdefinitions-1.5.0.3576.tar.bz2"
+
+SLOT="4.0"
+
+KEYWORDS="amd64 x86"
+
+# Comprehensive list of any and all USE flags leveraged in the ebuild,
+# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
+# "x86" and "alpha". This is a required variable. If the ebuild doesn't
+# use any USE flags, set to "".
+IUSE=""
+
+# A space delimited list of portage features to restrict. man 5 ebuild
+# for details. Usually not needed.
+#RESTRICT="strip"
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+#DEPEND=""
+
+# Run-time dependencies. Must be defined to whatever this depends on to run.
+# The below is valid if the same run-time depends are required to compile.
+RDEPEND="${DEPEND}"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
+# If you don't need to change it, leave the S= line out of the ebuild
+# to keep it tidy.
+#S="${WORKDIR}/${P}"
+
+#src_prepare() {
+ # Esto es principalmente para aplicar parches
+#}
+
+src_compile() {
+ econf --prefix=/opt/datys || die "econf failed"
+ emake || die "Error de compilación"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+