summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 12:49:29 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 12:49:29 -0400
commit45e3102beffd0f9eefdf79281d8ccd20cd36d951 (patch)
treeebfd4cb9b6bc1bfae289d93b7dcb42b5424a3381
parent20100719 - Cambio automático (diff)
downloadrubenqba-45e3102beffd0f9eefdf79281d8ccd20cd36d951.tar.gz
rubenqba-45e3102beffd0f9eefdf79281d8ccd20cd36d951.tar.bz2
rubenqba-45e3102beffd0f9eefdf79281d8ccd20cd36d951.zip
adicionando mutter-2.31.4
-rw-r--r--x11-wm/mutter/mutter-2.31.4.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/x11-wm/mutter/mutter-2.31.4.ebuild b/x11-wm/mutter/mutter-2.31.4.ebuild
new file mode 100644
index 0000000..6689102
--- /dev/null
+++ b/x11-wm/mutter/mutter-2.31.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Upcoming GNOME 3 window manager (derived from metacity)"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +introspection +sound test xinerama"
+
+RDEPEND=">=x11-libs/gtk+-2.90:3[introspection?]
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.14
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ >=media-libs/clutter-1.2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ sound? ( media-libs/libcanberra[gtk3] )
+ introspection? ( dev-libs/gobject-introspection )
+ xinerama? ( x11-libs/libXinerama )
+ gnome-extra/zenity
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings
+ --with-gtk=3.0
+ $(use_with sound libcanberra)
+ $(use_with introspection)
+ $(use_enable xinerama)"
+}
+