summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/goaccess/goaccess-0.9.7.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-0.9.7.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-analyzer/goaccess/goaccess-0.9.7.ebuild b/net-analyzer/goaccess/goaccess-0.9.7.ebuild
new file mode 100644
index 0000000..121b7fb
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.9.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.io"
+SRC_URI="http://tar.goaccess.io/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="btree debug geoip getline tokyocabinet unicode"
+
+REQUIRED_USE="btree? ( tokyocabinet )"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+ !tokyocabinet? ( dev-libs/glib:2 )
+ tokyocabinet? (
+ dev-db/tokyocabinet
+ btree? (
+ app-arch/bzip2
+ sys-libs/zlib
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+
+ epatch "${FILESDIR}/fix_libtinfo_linking.patch" # this patch is already on master branch
+
+ # Fix path to GeoIP bases in config
+ sed -e s':/usr/local:/usr:' -i config/goaccess.conf || die
+}
+
+src_configure() {
+ eautoreconf -fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable geoip) \
+ $(use_enable unicode utf8) \
+ $(use_enable tokyocabinet tcb) \
+ $(use_enable btree bzip) \
+ $(use_enable btree zlib) \
+ $(use_enable btree zlib) \
+ $(usex tokyocabinet "--enable-tcb=$(usex btree btree memhash)" '') \
+ $(use_with getline)
+}