summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/xh/xh-0.18.0.ebuild')
-rw-r--r--net-misc/xh/xh-0.18.0.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/net-misc/xh/xh-0.18.0.ebuild b/net-misc/xh/xh-0.18.0.ebuild
index 93653d2..acb99e9 100644
--- a/net-misc/xh/xh-0.18.0.ebuild
+++ b/net-misc/xh/xh-0.18.0.ebuild
@@ -257,15 +257,29 @@ LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD ISC MIT MPL-2.0 Unicode-DFS-2016"
SLOT="0"
RESTRICT="mirror"
+IUSE="+rustls"
QA_FLAGS_IGNORED="usr/bin/${PN}"
src_unpack() {
if [[ ${PV} == *9999* ]]; then
git-r3_src_unpack
- rm -f "${S}"/Cargo.lock
cargo_live_src_unpack
else
cargo_src_unpack
fi
}
+
+src_configure() {
+ myfeatures=(
+ $(usex rustls rustls native-tls)
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ dosym /usr/bin/"${PN}" /usr/bin/"s${PN}"
+}