summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2024-06-17 15:37:03 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2024-06-17 15:37:03 +0800
commitc5fea747e4c885f48f49349b46c23e9e1834735d (patch)
tree3ca850e0dffb9d0ec5bd72e8ae5ebd53821979c6
parent[app-misc/jnv] upgrade from upstream (diff)
downloadpigfoot-c5fea747e4c885f48f49349b46c23e9e1834735d.tar.gz
pigfoot-c5fea747e4c885f48f49349b46c23e9e1834735d.tar.bz2
pigfoot-c5fea747e4c885f48f49349b46c23e9e1834735d.zip
[app-admin/mongosh-bin] New ebuild
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--app-admin/mongosh-bin/Manifest2
-rw-r--r--app-admin/mongosh-bin/mongosh-bin-2.2.9.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/mongosh-bin/Manifest b/app-admin/mongosh-bin/Manifest
new file mode 100644
index 0000000..0333b2b
--- /dev/null
+++ b/app-admin/mongosh-bin/Manifest
@@ -0,0 +1,2 @@
+DIST mongosh-2.2.9_arm64.tgz 80370162 BLAKE2B 594e162a873abe5c21d25402e16c891e20749eb02f5f44956bd110f98842ce1bb3c6bf273ead7159c7ba4d98f05e0e5261426f8a13933e36060df90c0ef4fc45 SHA512 a6c40c85c6afe51c9a4733c79e5ce9741c9598940d2ef2c639bed29a1076d2eb73f6096fe0279c226649058af0f705d2d6a5b5a89df884805cc99e7da55985e9
+DIST mongosh-2.2.9_x64.tgz 81399973 BLAKE2B 1d799a60cbcd4142c57898a24da95f3042931b0c173f5e63aaacb97de66d4b9622ca78a27c78c97b9099e7259aadbd5c91e2d0164a27845be27aaefbfc48c7ea SHA512 8a7770057d5cc2bf0c0a32debc42b97ec205f51a7f010b15ad136b5e7be21d49e9eb838cf28a53aaa36c82ff8bb2c76fb1ce9bd0a5baab1b9a0f8dfdded4c9ec
diff --git a/app-admin/mongosh-bin/mongosh-bin-2.2.9.ebuild b/app-admin/mongosh-bin/mongosh-bin-2.2.9.ebuild
new file mode 100644
index 0000000..2b5a1f1
--- /dev/null
+++ b/app-admin/mongosh-bin/mongosh-bin-2.2.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN%-bin}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The MongoDB Shell"
+HOMEPAGE="https://github.com/mongodb-js/mongosh https://www.mongodb.com/products/shell"
+
+SRC_URI_BASE="https://downloads.mongodb.com/compass/${MY_P}-linux"
+SRC_URI="amd64? ( ${SRC_URI_BASE}-x64.tgz -> ${MY_P}_x64.tgz )
+ arm64? ( ${SRC_URI_BASE}-arm64.tgz -> ${MY_P}_arm64.tgz )"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-4.0 ISC MIT WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="dev-libs/cyrus-sasl[kerberos]"
+
+# Do not complain about CFLAGS etc since we don't use them
+QA_FLAGS_IGNORED='.*'
+
+src_unpack() {
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-linux-x64"
+ elif use arm64; then
+ S="${WORKDIR}/${MY_P}-linux-arm64"
+ fi
+
+ default
+}
+
+src_install() {
+ dobin bin/mongosh
+}