summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2024-02-14 17:36:16 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2024-02-14 17:36:16 +0800
commit4eefa563c70b2fb1a280cb41233fb6dacc8d8558 (patch)
treece360d8b27ef64c34d144d9adda12a60e6b69e80
parent[net-misc/BaiduPCS-Go] upgrade from upstream (diff)
downloadpigfoot-4eefa563c70b2fb1a280cb41233fb6dacc8d8558.tar.gz
pigfoot-4eefa563c70b2fb1a280cb41233fb6dacc8d8558.tar.bz2
pigfoot-4eefa563c70b2fb1a280cb41233fb6dacc8d8558.zip
[app-admin/google-compute-engine] support python 3.12
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--app-admin/google-compute-engine/google-compute-engine-20191210-r3.ebuild (renamed from app-admin/google-compute-engine/google-compute-engine-20191210-r2.ebuild)19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-admin/google-compute-engine/google-compute-engine-20191210-r2.ebuild b/app-admin/google-compute-engine/google-compute-engine-20191210-r3.ebuild
index 43adf5a..95b287c 100644
--- a/app-admin/google-compute-engine/google-compute-engine-20191210-r2.ebuild
+++ b/app-admin/google-compute-engine/google-compute-engine-20191210-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 systemd
@@ -37,18 +37,17 @@ DESCRIPTION="Scripts and tools for Google Compute Engine Linux images."
HOMEPAGE="https://github.com/GoogleCloudPlatform/compute-image-packages"
LICENSE="Apache-2.0"
-SLOT="0/${PVR}"
-KEYWORDS="~amd64 ~x86"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 x86"
IUSE="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror"
distutils_enable_tests pytest
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/distro[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}"
+RDEPEND="
+ dev-python/distro[${PYTHON_USEDEP}]
+"
S="${WORKDIR}/${MY_P}/packages/python-google-compute-engine"