summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2023-09-14 16:59:44 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2023-09-14 16:59:44 +0800
commit259545eb919dc189e43fbe52d11756bb0f26462e (patch)
tree6189097fd2eaa175804193e5d4a1a81fbeca2383
parent[net-misc/ipinfo] upgrade from upstream (diff)
downloadpigfoot-259545eb919dc189e43fbe52d11756bb0f26462e.tar.gz
pigfoot-259545eb919dc189e43fbe52d11756bb0f26462e.tar.bz2
pigfoot-259545eb919dc189e43fbe52d11756bb0f26462e.zip
[net-dns/dog] new ebuild
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-dns/dog/dog-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dns/dog/dog-9999.ebuild b/net-dns/dog/dog-9999.ebuild
new file mode 100644
index 0000000..59af2f0
--- /dev/null
+++ b/net-dns/dog/dog-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999 ]]; then
+ CRATES=""
+ declare -A GIT_CRATES=(
+ )
+fi
+
+inherit cargo
+
+DESCRIPTION="A command-line DNS client"
+HOMEPAGE="https://dns.lookup.dog/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ogham/${PN}"
+ inherit git-r3
+else
+ [[ ${PV} == *_pre???????? ]] && COMMIT="721440b12ef01a812abe5dc6ced69af6e221fad5"
+
+ SRC_URI="https://github.com/ogham/${PN}/archive/${COMMIT:-${PV}}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
+ S="${WORKDIR}/${PN}-${COMMIT:-${PV}}"
+ KEYWORDS="amd64 x86 arm arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ rm -f "${S}"/Cargo.lock
+ cargo_live_src_unpack
+ else
+ cargo_src_unpack
+ fi
+}