summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2022-03-11 19:01:51 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2022-03-11 19:01:51 +0800
commit110cb891c60a0c779eccf4bef589573b6d4714b3 (patch)
tree9617b96b8e6457ebb2c5c71c1a11f6b3e1874394
parentRemove out-of-dated packages (diff)
downloadpigfoot-110cb891c60a0c779eccf4bef589573b6d4714b3.tar.gz
pigfoot-110cb891c60a0c779eccf4bef589573b6d4714b3.tar.bz2
pigfoot-110cb891c60a0c779eccf4bef589573b6d4714b3.zip
[net-analyzer/amass] new ebuild
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-analyzer/amass/Manifest1
l---------net-analyzer/amass/amass-3.17.1.ebuild1
-rw-r--r--net-analyzer/amass/amass-9999.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/amass/Manifest b/net-analyzer/amass/Manifest
new file mode 100644
index 0000000..625298d
--- /dev/null
+++ b/net-analyzer/amass/Manifest
@@ -0,0 +1 @@
+DIST amass-3.17.1.tar.gz 20479176 BLAKE2B 3d2239f34df6a63ac4b5ddbe435a169e557e3369314f33fb83ac34157f77cba78d8383b7b1597ff936ab2990f147bc6920824468a6db650c234572d9981a2ff3 SHA512 5cf463769b3770e49ffe2dcf2f5f3ac7b9b6a42826f9d84c3d83f2e31fef6da6679893a4e1b4b18cf41c86f8253e34b7c17a584f637ff6ca4e8a45a4074e9a2f
diff --git a/net-analyzer/amass/amass-3.17.1.ebuild b/net-analyzer/amass/amass-3.17.1.ebuild
new file mode 120000
index 0000000..b8b9cff
--- /dev/null
+++ b/net-analyzer/amass/amass-3.17.1.ebuild
@@ -0,0 +1 @@
+amass-9999.ebuild \ No newline at end of file
diff --git a/net-analyzer/amass/amass-9999.ebuild b/net-analyzer/amass/amass-9999.ebuild
new file mode 100644
index 0000000..f868e67
--- /dev/null
+++ b/net-analyzer/amass/amass-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/OWASP/Amass"
+
+inherit go-module
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+
+ src_unpack() {
+ git-r3_src_unpack
+ #go-module_live_vendor
+ }
+else
+ EGO_VER="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
+
+ #EGO_SUM=(
+ #)
+ #go-module_set_globals
+
+ SRC_URI+="${EGO_SUM_SRC_URI}"
+ S="${WORKDIR}/Amass-${PV}"
+ KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
+fi
+
+DESCRIPTION="In-depth Attack Surface Mapping and Asset Discovery"
+LICENSE="Apache-2.0"
+SLOT="0/${PVR}"
+RESTRICT="mirror"
+IUSE="+pie"
+
+src_compile() {
+ # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
+ # https://github.com/golang/go/issues/18968
+ use pie && local build_pie="-buildmode=pie"
+
+ local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+
+ set -- env \
+ GOCACHE="${T}/go-cache" \
+ CGO_ENABLED=0 \
+ go build -o "bin/${PN}" -mod=readonly -v -work -x ${build_flags} \
+ ./cmd/${PN}
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin bin/${PN}
+
+ insinto /etc/amass
+ doins "${FILESDIR}"/examples/config.ini
+}