summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/networkmanager-strongswan/networkmanager-strongswan-1.1.2.ebuild')
-rw-r--r--net-misc/networkmanager-strongswan/networkmanager-strongswan-1.1.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/networkmanager-strongswan/networkmanager-strongswan-1.1.2.ebuild b/net-misc/networkmanager-strongswan/networkmanager-strongswan-1.1.2.ebuild
new file mode 100644
index 0000000..d761d48
--- /dev/null
+++ b/net-misc/networkmanager-strongswan/networkmanager-strongswan-1.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils versionator
+
+# NetworkManager likes itself with capital letters
+MY_P=${P/networkmanager/NetworkManager}
+MYPV_MINOR=$(get_version_component_range 1-2)
+
+DESCRIPTION="NetworkManager StrongSwan plugin."
+HOMEPAGE="http://www.strongswan.org/"
+SRC_URI="http://download.strongswan.org/NetworkManager/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-misc/networkmanager-0.7
+ >=net-misc/strongswan-4.3.3[networkmanager]"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ECONF="--disable-more-warnings \
+ --with-charon=/usr/libexec/ipsec/charon"
+
+ econf ${ECONF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc NEWS || die "dodoc failed"
+}