summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authormaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2008-12-11 22:13:49 +0000
committermaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2008-12-11 22:13:49 +0000
commit43d8d8eb93719dbd55a33fa757ea4893fa462612 (patch)
treed336092e20d7fc3730c22d6a740d35a18c8df928 /net-im
parentmplayer-1.0_rc2_p28058 with coreavc use flag (diff)
downloadpiczu-43d8d8eb93719dbd55a33fa757ea4893fa462612.tar.gz
piczu-43d8d8eb93719dbd55a33fa757ea4893fa462612.tar.bz2
piczu-43d8d8eb93719dbd55a33fa757ea4893fa462612.zip
gajim 0.12 beta1 added
git-svn-id: http://piczu-overlay.googlecode.com/svn/trunk@29 0805d722-a2c2-11dd-9b86-41075523de00
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/Manifest2
-rw-r--r--net-im/gajim/gajim-0.12_beta1.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
new file mode 100644
index 0000000..54551ab
--- /dev/null
+++ b/net-im/gajim/Manifest
@@ -0,0 +1,2 @@
+DIST gajim-0.12-beta1.tar.gz 4850530 RMD160 de838a3ae4b8ae737e3bd8eb2e2ed91d47c5bca6 SHA1 682c0cb089b32256eb4764a2fe8f958b9967875d SHA256 54d65c32e6b33b5f7ed679cd617a42644738599f8cc05ffefdf6517250e18c83
+EBUILD gajim-0.12_beta1.ebuild 2618 RMD160 fed26080fa864ccd0ed70643883d53f912fded57 SHA1 d0f114d8c1b961db457bd7f2272d075dcee12a9e SHA256 d37fdfaecef8c0807d8532649a5fd4407eb9a9419d460cb53978cf7e60468144
diff --git a/net-im/gajim/gajim-0.12_beta1.ebuild b/net-im/gajim/gajim-0.12_beta1.ebuild
new file mode 100644
index 0000000..b25e890
--- /dev/null
+++ b/net-im/gajim/gajim-0.12_beta1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit multilib python eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="avahi dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+DEPEND="|| (
+ ( <dev-lang/python-2.5 dev-python/pysqlite )
+ >=dev-lang/python-2.5
+ )
+ dev-python/pygtk
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+RDEPEND="gnome? ( dev-python/gnome-python-extras
+ dev-python/gnome-python-desktop
+ )
+ dbus? ( dev-python/dbus-python dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ xhtml? ( dev-python/docutils )
+ srv? ( net-dns/bind-tools )
+ idle? ( x11-libs/libXScrnSaver )
+ spell? ( app-text/gtkspell )
+ avahi? ( net-dns/avahi )
+ dev-python/pyopenssl"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ else
+ if has_version "<sys-apps/dbus-0.90" && ! built_with_use sys-apps/dbus python; then
+ eerror "Please rebuild dbus with USE=\"python\""
+ die "USE=\"python\" needed for dbus"
+ fi
+ fi
+
+ if use avahi; then
+ if ! built_with_use net-dns/avahi dbus gtk python; then
+ eerror "The following USE flags are required for correct avahi"
+ eerror "support: dbus gtk python"
+ die "Please rebuild avahi with these use flags enabled."
+ fi
+ fi
+
+ if has_version ">=dev-lang/python-2.5" && ! built_with_use dev-lang/python sqlite; then
+ eerror "Please rebuild python with USE=\"sqlite\""
+ die "USE=\"sqlite\" needed for python"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if ! use gnome; then
+ myconf="${myconf} $(use_enable trayicon)"
+ myconf="${myconf} $(use_enable idle)"
+ fi
+
+ econf $(use_enable nls) \
+ $(use_enable spell gtkspell) \
+ $(use_enable dbus remote) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --prefix="/usr" \
+ --libdir="/usr/$(get_libdir)" \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/README.html"
+ dohtml README.html
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/gajim/
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/gajim/
+}