summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2010-04-05 21:02:54 +0000
committermaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2010-04-05 21:02:54 +0000
commit95229319b88e8746e46d1758358987b6a280a518 (patch)
tree1ed055f0453e416e9dc5db9b6900d5dbea0c668a
parentavant-window-navigator ebuild cleanup (diff)
downloadpiczu-95229319b88e8746e46d1758358987b6a280a518.tar.gz
piczu-95229319b88e8746e46d1758358987b6a280a518.tar.bz2
piczu-95229319b88e8746e46d1758358987b6a280a518.zip
The Settlers 2 multiplayer mode ebuild
git-svn-id: http://piczu-overlay.googlecode.com/svn/trunk@91 0805d722-a2c2-11dd-9b86-41075523de00
-rw-r--r--games-strategy/s25rttr/Manifest3
-rw-r--r--games-strategy/s25rttr/s25rttr-0.6.ebuild58
2 files changed, 61 insertions, 0 deletions
diff --git a/games-strategy/s25rttr/Manifest b/games-strategy/s25rttr/Manifest
new file mode 100644
index 0000000..0a062fc
--- /dev/null
+++ b/games-strategy/s25rttr/Manifest
@@ -0,0 +1,3 @@
+DIST s25rttr_0.6_amd64.tar.bz2 6100037 RMD160 1ff22b6615bd2d016d7f36e22a4ec0e477f78789 SHA1 2f65edb80bedba31ba495b6a08a0b1c62abeffb5 SHA256 0b0e844726257b8d7f6ab3ac502d9aeb7dc86465af5caf95c9d358e01183ac99
+DIST s25rttr_0.6_x86.tar.bz2 6008481 RMD160 25fb758534b3d952fce5302894e0c5f92fd441ea SHA1 bb373dfb87307781d11adf56688a89627317f662 SHA256 e0b373854a7658b18e903adb35d24daeb34473d96cd66c1433a825d88dfa8768
+EBUILD s25rttr-0.6.ebuild 1076 RMD160 ecfd772979b6e7c29b46546176614a305047cda1 SHA1 549531a176d9cc8afcadc5c07df2524998adc814 SHA256 83798f95c65078e8ec9eb54e4f93e67b182a36fad6d66eb920b97abfb40620c6
diff --git a/games-strategy/s25rttr/s25rttr-0.6.ebuild b/games-strategy/s25rttr/s25rttr-0.6.ebuild
new file mode 100644
index 0000000..db79000
--- /dev/null
+++ b/games-strategy/s25rttr/s25rttr-0.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit games
+
+if [ ${PV} = "9999" ]; then
+ EBZR_REPO_URI="lp:s25rttr"
+ inherit bzr
+ SRC_URI=""
+fi
+
+DESCRIPTION="Opensource remake of The Settlers II game"
+HOMEPAGE="http://www.siedler25.org/"
+
+if [ ! ${PV} = "9999" ]; then
+ S_U="http://launchpad.net/s25rttr/s25client/0.6/+download/${P/-/_}"
+ SRC_URI="x86? ( ${S_U}_x86.tar.bz2 )
+ amd64? ( ${S_U}_amd64.tar.bz2 )"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="media-libs/libsndfile
+ media-libs/libsamplerate
+ =media-libs/sdl-mixer-1.2*
+ sys-devel/gettext"
+# media-libs/libtimidity"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/-/_}"
+
+src_install() {
+ into /opt/${PN}
+ insinto /opt/${PN}
+ dobin bin/s25client
+ doins -r lib share
+ dodoc *.txt
+
+ cat <<- EOF > s25client
+ #!/usr/bin/env bash
+ cd /opt/s25rttr
+ bin/s25client
+
+ EOF
+
+ dogamesbin s25client
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Copy or symlink your original game files to /opt/s25rttr/share/s25rttr/S2/"
+}