summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2019-07-17 09:25:21 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2019-07-17 09:25:21 -0700
commit9051064253b0f590e626d67912dd05cfb0dde995 (patch)
treebb44481d32f73e939250ec197278944e747a9bb2
parentI need to figure out how to develop better here (diff)
downloadpalmer-9051064253b0f590e626d67912dd05cfb0dde995.tar.gz
palmer-9051064253b0f590e626d67912dd05cfb0dde995.tar.bz2
palmer-9051064253b0f590e626d67912dd05cfb0dde995.zip
dev-python/proboscis: New ebuild
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-rw-r--r--dev-python/proboscis/Manifest1
-rw-r--r--dev-python/proboscis/files/proboscis-1.2.6.0-python3_6.patch31
-rw-r--r--dev-python/proboscis/proboscis-1.2.6.0.ebuild24
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/proboscis/Manifest b/dev-python/proboscis/Manifest
new file mode 100644
index 0000000..bf6ce6e
--- /dev/null
+++ b/dev-python/proboscis/Manifest
@@ -0,0 +1 @@
+DIST proboscis-1.2.6.0.tar.gz 19901 BLAKE2B 068a32bb6f493b58cead3451e9c77025bed33efd586558b91f3e8143415d85ca059b8adb8da388720a5cda7c294a82d694920bf2e12a1636dffc1d45101e17f9 SHA512 74a5b0d76eb8bd78026b6dfc1bff0e3ad4fd4bde944a698ffd306e593365b5b8e65b53efde72ecfec4ed70c123216b9810e96595af74a568015c678e44b38642
diff --git a/dev-python/proboscis/files/proboscis-1.2.6.0-python3_6.patch b/dev-python/proboscis/files/proboscis-1.2.6.0-python3_6.patch
new file mode 100644
index 0000000..0926235
--- /dev/null
+++ b/dev-python/proboscis/files/proboscis-1.2.6.0-python3_6.patch
@@ -0,0 +1,31 @@
+diff --git a/proboscis/compatability/exceptions_2_5.py b/proboscis/compatability/exceptions_2_5.py
+index 3a37c9ca700c..d01bb886cdbc 100644
+--- a/proboscis/compatability/exceptions_2_5.py
++++ b/proboscis/compatability/exceptions_2_5.py
+@@ -18,14 +18,14 @@ def capture_exception(body_func, *except_type):
+ try:
+ body_func()
+ return None
+- except except_type, e:
++ except (except_type, e):
+ return e
+
+
+ def capture_type_error(func):
+ try:
+ func()
+- except TypeError, te:
++ except (TypeError, te):
+ msg = str(te)
+ if ("takes exactly 1 argument" in msg and "(0 given)" in msg) \
+ or "instance as first argument (got nothing instead)" in msg:
+diff --git a/proboscis/compatability/raise_2_x.py b/proboscis/compatability/raise_2_x.py
+index 21ceca51f2ec..8aa73f919adc 100644
+--- a/proboscis/compatability/raise_2_x.py
++++ b/proboscis/compatability/raise_2_x.py
+@@ -15,4 +15,4 @@
+
+
+ def raise_with_traceback(_type, exception, traceback):
+- raise _type, exception, traceback
++ raise (_type, exception, traceback)
diff --git a/dev-python/proboscis/proboscis-1.2.6.0.ebuild b/dev-python/proboscis/proboscis-1.2.6.0.ebuild
new file mode 100644
index 0000000..b2c7d5d
--- /dev/null
+++ b/dev-python/proboscis/proboscis-1.2.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION=""
+HOMEPAGE=""
+SRC_URI="https://files.pythonhosted.org/packages/3c/c8/c187818ab8d0faecdc3c16c1e0b2e522f3b38570f0fb91dcae21662019d0/${P}.tar.gz"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-python3_6.patch"
+)