summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywapi/pywapi-0.3.8.ebuild')
-rw-r--r--dev-python/pywapi/pywapi-0.3.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pywapi/pywapi-0.3.8.ebuild b/dev-python/pywapi/pywapi-0.3.8.ebuild
new file mode 100644
index 0000000..430cbd6
--- /dev/null
+++ b/dev-python/pywapi/pywapi-0.3.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around multiple weather APIs"
+HOMEPAGE="https://launchpad.net/python-weather-api"
+SRC_URI="https://launchpad.net/python-weather-api/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}