summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2024-07-06 08:06:41 +0200
committerMartin Väth <martin@mvath.de>2024-07-06 08:06:41 +0200
commit584558d99c1aefa0912e3e177093ca7d6abfd1e0 (patch)
tree0ef38a871656ea6e0f48fc74e0ac9ef4321f1417
parentsys-apps/less: Version bump. media-video/luvcview: Copy from gentoo repository (diff)
downloadmv-584558d99c1aefa0912e3e177093ca7d6abfd1e0.tar.gz
mv-584558d99c1aefa0912e3e177093ca7d6abfd1e0.tar.bz2
mv-584558d99c1aefa0912e3e177093ca7d6abfd1e0.zip
media-video/luvcview: Add patch for gcc-14
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--media-video/luvcview/files/luvcview-0.2.6-includes.patch33
-rw-r--r--media-video/luvcview/luvcview-0.2.6-r1.ebuild1
2 files changed, 34 insertions, 0 deletions
diff --git a/media-video/luvcview/files/luvcview-0.2.6-includes.patch b/media-video/luvcview/files/luvcview-0.2.6-includes.patch
new file mode 100644
index 00000000..6ea3b63a
--- /dev/null
+++ b/media-video/luvcview/files/luvcview-0.2.6-includes.patch
@@ -0,0 +1,33 @@
+Martin V\"ath <martin at mvath.de>:
+Fix missing includes and function declarations of luvcview-0.2.6 which make
+compilation fail on, for instance, gcc-14.
+--- 1/v4l2uvc.c
++++ 1/v4l2uvc.c
+@@ -25,6 +25,7 @@
+ #include <math.h>
+ #include <float.h>
+
++#include <SDL/SDL.h>
+ #include <libv4l2.h>
+
+ #include "v4l2uvc.h"
+--- 1/v4l2uvc.h
++++ 1/v4l2uvc.h
+@@ -90,13 +90,17 @@
+ int uvcGrab(struct vdIn *vd);
+ int close_v4l2(struct vdIn *vd);
+
++int check_videoIn(struct vdIn *vd, char *device);
++
+ int v4l2GetControl(struct vdIn *vd, int control);
+ int v4l2SetControl(struct vdIn *vd, int control, int value);
+ int v4l2UpControl(struct vdIn *vd, int control);
+ int v4l2DownControl(struct vdIn *vd, int control);
+ int v4l2ToggleControl(struct vdIn *vd, int control);
+ int v4l2ResetControl(struct vdIn *vd, int control);
++int v4l2ResetPan(struct vdIn *vd);
+ int v4l2ResetPanTilt(struct vdIn *vd);
++int v4l2ResetTilt(struct vdIn *vd);
+ int v4L2UpDownPan(struct vdIn *vd, short inc);
+ int v4L2UpDownTilt(struct vdIn *vd,short inc);
+ int v4L2UpDownPanTilt(struct vdIn *vd, short inc_p, short inc_t);
diff --git a/media-video/luvcview/luvcview-0.2.6-r1.ebuild b/media-video/luvcview/luvcview-0.2.6-r1.ebuild
index 76fab30b..bc5623f9 100644
--- a/media-video/luvcview/luvcview-0.2.6-r1.ebuild
+++ b/media-video/luvcview/luvcview-0.2.6-r1.ebuild
@@ -29,6 +29,7 @@ src_prepare() {
default
eapply "${WORKDIR}"/${PN}_${PV}-${PATCH_LEVEL}.diff
eapply debian/patches/*.patch
+ eapply "${FILESDIR}/${P}-includes.patch"
sed -i -e 's:videodev.h:videodev2.h:' *.{c,h} || die
sed -i -e 's:-O2::' Makefile || die
}