summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2023-05-18 20:40:27 +0200
committerMartin Väth <martin@mvath.de>2023-05-18 20:40:27 +0200
commit0c526b15d56fce2ebd13ea969c066534b136c6c5 (patch)
tree29b0c5891ebe0738e2cdc69c3760db7199c4cfd0
parentnet-firewall/firewall-mv: Version bump (diff)
downloadmv-0c526b15d56fce2ebd13ea969c066534b136c6c5.tar.gz
mv-0c526b15d56fce2ebd13ea969c066534b136c6c5.tar.bz2
mv-0c526b15d56fce2ebd13ea969c066534b136c6c5.zip
sys-block/zram-init: Add missing eclass
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--sys-block/zram-init/zram-init-11.1-r2.ebuild (renamed from sys-block/zram-init/zram-init-11.1-r1.ebuild)21
2 files changed, 15 insertions, 8 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 2251c535..a42149eb 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -106,7 +106,7 @@ sys-apps/schedule 8.0.1-r2: script to schedule jobs in a multiuser multitasking
sys-apps/starter 3.0-r1: POSIX shell script and function to schedule commands
sys-apps/systemd-tmpfiles-openrc 1: openrc init-files for systemd-tmpfiles from sys-apps/systemd
sys-block/parted 2.4-r3: Create, destroy, resize, check, copy partitions and file systems
-sys-block/zram-init 11.1-r1: Scripts to support compressed swap devices or ramdisks with zram
+sys-block/zram-init 11.1-r2: Scripts to support compressed swap devices or ramdisks with zRAM
sys-boot/grub-cfg-mv 1.8: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.5: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14-r1: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
diff --git a/sys-block/zram-init/zram-init-11.1-r1.ebuild b/sys-block/zram-init/zram-init-11.1-r2.ebuild
index 8adcda70..f982f484 100644
--- a/sys-block/zram-init/zram-init-11.1-r1.ebuild
+++ b/sys-block/zram-init/zram-init-11.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2011-2022 Martin V\"ath
+# Copyright 2011-2023 Martin V\"ath and Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit readme.gentoo-r1
+inherit readme.gentoo-r1 systemd
RESTRICT="mirror" # until available on gentoo mirrors
-DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
+DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zRAM"
HOMEPAGE="https://github.com/vaeth/zram-init/"
SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -20,14 +20,21 @@ done
BDEPEND="nls? ( sys-devel/gettext )"
RDEPEND="app-shells/push:0/1
- !<sys-apps/openrc-0.13
- nls? ( virtual/libintl )"
+ nls? ( virtual/libintl )
+ || ( sys-apps/openrc sys-apps/systemd )
+"
DISABLE_AUTOFORMATTING="true"
DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
rc-config add zram default
-If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
-You might need to modify /etc/modprobe.d/zram.conf"
+If you use systemd enable zram_swap, zram_tmp, and/or zram_var_tmp with
+systemctl. You might need to modify /etc/modprobe.d/zram.conf.
+If you use the \$TMPDIR as zram device with OpenRC, you should add zram-init to
+the boot runlevel:
+ rc-update add zram-init boot
+Still for the same case, you should add in the OpenRC configuration file for
+the services using \$TMPDIR the following line:
+rc_need=\"zram-init\""
src_compile() {
SHEBANG="#!${EPREFIX}$(get_usr)/bin/sh" \