summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Haegler <simon.haegler@mistafunk.ch>2011-10-17 17:04:55 +0200
committerSimon Haegler <simon.haegler@mistafunk.ch>2011-10-17 17:04:55 +0200
commit939c44a1c77569bbd5fa3c9c7505a4fcdaad21fe (patch)
tree5bbbfc3ae04244f2ab1461e11a6bc9fafabbcbb5
parentignore filter (diff)
downloadmistafunk-939c44a1c77569bbd5fa3c9c7505a4fcdaad21fe.tar.gz
mistafunk-939c44a1c77569bbd5fa3c9c7505a4fcdaad21fe.tar.bz2
mistafunk-939c44a1c77569bbd5fa3c9c7505a4fcdaad21fe.zip
updated to alembic 1.0.2
-rw-r--r--media-libs/alembic/Manifest2
-rw-r--r--media-libs/alembic/alembic-1.0.2.2011101200.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/media-libs/alembic/Manifest b/media-libs/alembic/Manifest
index 796b57e..8a3f311 100644
--- a/media-libs/alembic/Manifest
+++ b/media-libs/alembic/Manifest
@@ -1,3 +1,5 @@
DIST Alembic_1.0.1_2011091600.tgz 566444 RMD160 e2de15236d76e91839df29724a12ac6ef109e3c9 SHA1 8d0760c07eb26d70865e10e3470be4f43c0e620e SHA256 dfc499280a59a179e09e159884e0ab60b5f3335566cb4db2c5f94c88a1f50653
+DIST Alembic_1.0.2_2011101200.tgz 574206 RMD160 c4eccd05783fe36ced6324616cd16602a0f3fb58 SHA1 b8230399370a8f54b5a3395f087516bae0a5f3df SHA256 e66fd41dd42d55d91721afec3d019a8bfc657e2642bc1d0ee5c611729e9f2c71
EBUILD alembic-1.0.1.2011091600.ebuild 2267 RMD160 6525b0a1decd6118c0f21ba2e8af24ea2e57c4d8 SHA1 e3978bb5fa9043deb30114e287075f77c28e7035 SHA256 151f11583c90e1b73976f9ee07bb487c2e93e20f0ba7f4161cf72ec3d40874fe
+EBUILD alembic-1.0.2.2011101200.ebuild 2267 RMD160 6525b0a1decd6118c0f21ba2e8af24ea2e57c4d8 SHA1 e3978bb5fa9043deb30114e287075f77c28e7035 SHA256 151f11583c90e1b73976f9ee07bb487c2e93e20f0ba7f4161cf72ec3d40874fe
EBUILD alembic-9999.ebuild 2041 RMD160 de599413bfd7288f9677743dc44287bd18276ee2 SHA1 1f1acbd5537952f324f5dccd11079e401f6574ab SHA256 363446482e107d4ab87c513327e23341fe1524911dcc424f0e556c086fd01198
diff --git a/media-libs/alembic/alembic-1.0.2.2011101200.ebuild b/media-libs/alembic/alembic-1.0.2.2011101200.ebuild
new file mode 100644
index 0000000..d68fb0e
--- /dev/null
+++ b/media-libs/alembic/alembic-1.0.2.2011101200.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+
+EAPI=2
+
+inherit eutils versionator
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data that includes a C++ library, a file format, and client plugins and applications."
+HOMEPAGE="http://code.google.com/p/alembic"
+
+MY_PN="Alembic"
+MY_PV=$(replace_version_separator 3 '_')
+MY_P="${MY_PN}_${MY_PV}"
+MY_PV_NODATE=$(get_version_component_range 1-3)
+
+SRC_URI="http://alembic.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${MY_P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/${PN}-${MY_PV_NODATE}/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${MY_P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${MY_P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+}