summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre PIGNÉ <alex@freesenses.net>2012-02-13 07:53:35 +0100
committerAlexandre PIGNÉ <alex@freesenses.net>2012-02-13 07:53:35 +0100
commit1a3b7df297c61e4be6635b21d08963956e65fe76 (patch)
treed504bdbd0045c2d9b98cdbc34ae39c38c02f5b5b
downloadlootr-1a3b7df297c61e4be6635b21d08963956e65fe76.tar.gz
lootr-1a3b7df297c61e4be6635b21d08963956e65fe76.tar.bz2
lootr-1a3b7df297c61e4be6635b21d08963956e65fe76.zip
First ebuild of netzob including 3 other not existing dependencies.
Very basic setup.
-rw-r--r--bitarray-0.5.1.ebuild27
-rw-r--r--netzob-0.3.1.ebuild53
-rw-r--r--nfqueue-bindings-0.3.ebuild58
-rw-r--r--pcapy-0.10.5.ebuild28
4 files changed, 166 insertions, 0 deletions
diff --git a/bitarray-0.5.1.ebuild b/bitarray-0.5.1.ebuild
new file mode 100644
index 0000000..8728a8f
--- /dev/null
+++ b/bitarray-0.5.1.ebuild
@@ -0,0 +1,27 @@
+
+EAPI=4
+PYTHON_SUPPORT="2:2.5 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Efficient arrays of booleans extension for Python"
+HOMEPAGE="https://github.com/ilanschnell/bitarray http://pypi.python.org/pypi/bitarray"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORD="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+}
diff --git a/netzob-0.3.1.ebuild b/netzob-0.3.1.ebuild
new file mode 100644
index 0000000..0dae41a
--- /dev/null
+++ b/netzob-0.3.1.ebuild
@@ -0,0 +1,53 @@
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="Netzob-${PV}"
+
+DESCRIPTION="Network protocol modelization by reverse engineering"
+HOMEPAGE="http://www.netzob.org/"
+SRC_URI="http://www.netzob.org/repository/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORD="~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/ptrace-0.4.1
+ app-misc/hachoir-subfile
+ dev-python/matplotlib
+ dev-util/strace
+ sys-process/lsof
+ >=dev-python/lxml-2.3
+ dev-python/bitarray
+ net-libs/nfqueue-bindings[python]"
+# python-pcapy
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="README.txt AUTHORS.txt NEWS.txt COPYING.txt PKG-INFO.txt"
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+
+# if use doc; then
+# einfo "Generation of documentation"
+# pushd docs >/dev/null
+# emake html || die "Generation of documentation failed"
+# popd >/dev/null
+# fi
+}
+
+src_install() {
+ distutils_src_install
+}
diff --git a/nfqueue-bindings-0.3.ebuild b/nfqueue-bindings-0.3.ebuild
new file mode 100644
index 0000000..96f6176
--- /dev/null
+++ b/nfqueue-bindings-0.3.ebuild
@@ -0,0 +1,58 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit cmake-utils perl-module linux-info
+
+
+DESCRIPTION="nfqueue-bindings is a set of high-level modules for several
+languages (Python and Perl, for the moment), for libnetfilter_queue"
+HOMEPAGE="http://software.inl.fr/trac/wiki/nfqueue-bindings"
+SRC_URI="http://software.inl.fr/releases/nfqueue-bindings/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="perl python examples"
+
+DEPEND="python? (
+ virtual/python
+ dev-python/dpkt
+ )
+ perl? ( dev-lang/perl )
+ net-libs/libnetfilter_queue
+ dev-lang/swig"
+
+pkg_setup() {
+ # At least one of Python or Perl must be selected
+ useq python || useq perl || die "At least one supported language must be selected."
+ # Check kernel configuration for NFQUEUE
+ if linux_config_exists; then
+ ebegin "Checking NETFILTER_NETLINK_QUEUE support"
+ linux_chkconfig_present NETFILTER_NETLINK_QUEUE
+ eend $? || \
+ eerror 'Netfilter NFQUEUE over NFNETLINK interface support not found!'
+ ebegin "Checking NETFILTER_XT_TARGET_NFQUEUE support"
+ linux_chkconfig_present NETFILTER_XT_TARGET_NFQUEUE
+ eend $? || \
+ eerror '"NFQUEUE" target Support not found!'
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ perl_set_version
+ # Fix include Perl search directory
+ sed -i "/SET[[:space:]]*([[:space:]]*PERL_POSSIBLE_INCLUDE_PATHS/a\ ${ARCH_LIB}/CORE" ${P}/FindPerlLibs2.cmake
+ # Fix Perl destination directory
+ sed -i "/DESTINATION/s#\(perl\${PERL_VERSION}\)#\1/site_perl/${PERL_VERSION}/${ARCH_LIB##*/}#g" ${P}/perl/CMakeLists.txt
+ # Disable Perl/Python from USE flags
+ useq perl || sed -i '/ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*perl[[:space:]]*)/s/^/#/g' ${P}/CMakeLists.txt
+ useq python || sed -i '/ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*python[[:space:]]*)/s/^/#/g' ${P}/CMakeLists.txt
+}
+
+src_install() {
+ emake DESTDIR="${D}" install PREFIX=/usr || die
+ docinto examples
+ useq examples && dodoc examples/*
+}
diff --git a/pcapy-0.10.5.ebuild b/pcapy-0.10.5.ebuild
new file mode 100644
index 0000000..b45f1fa
--- /dev/null
+++ b/pcapy-0.10.5.ebuild
@@ -0,0 +1,28 @@
+
+EAPI=4
+PYTHON_SUPPORT="2:2.5 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python pcap extension"
+HOMEPAGE="http://oss.coresecurity.com/projects/pcapy.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ http://oss.coresecurity.com/repo/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORD="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+}