aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-05-23 18:17:13 +0100
committerPaul Healy <lmiphay@gmail.com>2019-05-23 18:17:13 +0100
commit17a64b605f92b337154f09d04839fe783fbc4d59 (patch)
tree30dc5cfad0206eddff7df31828844563d2829457 /sys-apps
parentbump zoom and drop gstreamer deps (diff)
downloadlmiphay-17a64b605f92b337154f09d04839fe783fbc4d59.tar.gz
lmiphay-17a64b605f92b337154f09d04839fe783fbc4d59.tar.bz2
lmiphay-17a64b605f92b337154f09d04839fe783fbc4d59.zip
revbump dstat
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dstat/Manifest3
-rw-r--r--sys-apps/dstat/dstat-0.7.4.ebuild42
-rw-r--r--sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch18
3 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/dstat/Manifest b/sys-apps/dstat/Manifest
index 0a89bf2..212f083 100644
--- a/sys-apps/dstat/Manifest
+++ b/sys-apps/dstat/Manifest
@@ -1,3 +1,6 @@
AUX dstat-0.7.3-skip-non-sandbox-tests.patch 705 BLAKE2B 3a20e75fd1aaed47d02066b7c889c13b4e1d8a2f8fd9772973d99736eb7cdf1fa9b8c04126beace166a6ac65de5de8743b904e9fa20d60a3aeae706f7ca41d18 SHA512 efa1c6a807efc7fabf8566ec446be94922e1fe78191101648dc066f107474f1b89c4c8cac51d6d1ba7d4b1061ce0358abf317761ce52199479667da1684f0929
+AUX dstat-0.7.4-skip-non-sandbox-tests.patch 661 BLAKE2B 31f98e58c8f23e3b6322de86bdddb83afa22b0b8bed48164378c6c071348ac2a37350b789985634017c1e338ceb73d7f9221d99e0b8b4b4d550f10d7840bde76 SHA512 0087d7fa2ce9388440bacdac52038433c1a7f0c5fd885027a4b18895c8f450cc7cae7610e6232e26393749f1b165c4ade5ee2a0e453c7e2542450f5a3d3100ac
DIST dstat-0.7.3.tar.gz 135583 BLAKE2B c846a06b6039e49944d43cc36178fed74fd4e0e3a1a4418dbe0e5987763995eb36dff0245cfa7107d446b8ac2ea500e13980f87e97aa8e5b8d566ee188be1639 SHA512 db37cc8bb7afd235ae9088e76c4defaa4d76651b111fbfdcd0980bc96376de20d57964912799a413397a79651730503bdeb8fea5cb97ab4d6d81632f528aefd2
+DIST dstat-0.7.4.tar.gz 139992 BLAKE2B c8226358956687a4f64e248ef539b431b9e394e87986366f9941df2e86f0dac3032261ec2ca9c816d3bc89afabc352bc8bc80f9ad3eaa6118fd16bd7b0f1e68e SHA512 d100223887ebd83d0fd1259436f39419a85df9002556abcfc8e4195aa63be73d85707dcd5c4fb56a979b29131485dce6e97c177fbfca08dc50bd0f92b15cc6f5
EBUILD dstat-0.7.3-r1.ebuild 865 BLAKE2B 60f79ac34d777a864ad9aaa154346323b7818e219833ff152597cf1f148f60439e19430e303b0ca3fc66c69538fde1d3744d91246fe5779644a73c77558fe52a SHA512 b4462000fcd9ff5554f6e3c5571997e0db595613efb13eaf7fe2a722a79e5115046039fd09ecac7578b661c6aec15a4180ff53f87dee51e17b3b9e11f95cfbe0
+EBUILD dstat-0.7.4.ebuild 924 BLAKE2B 35517215d40ad369be6eb0be9481829cf315b3c0f5d68b573741d33d0800f8502ccdfc9e4e997adc0623a46731e94a052958422b3816e46792c852f4b0d87a5a SHA512 6ea9441461d14e9314a06e2b8d315e822f816a242ad2882dec39907269b30e460b4db711e51763c20b7a23f2c05a859a941593cbf2a1bb2277888c269b628e52
diff --git a/sys-apps/dstat/dstat-0.7.4.ebuild b/sys-apps/dstat/dstat-0.7.4.ebuild
new file mode 100644
index 0000000..0843939
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="wifi doc examples"
+REQUIRED_USE="wifi? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ wifi? (
+ ${PYTHON_DEPS}
+ net-wireless/python-wifi
+ )"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" )
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_replicate_script "${ED}"/usr/bin/${PN}
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}
diff --git a/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch b/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch
new file mode 100644
index 0000000..38457cd
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index c371f62..42ef84d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,10 +32,12 @@ clean:
+ rm -f examples/*.pyc plugins/*.pyc
+ $(MAKE) -C docs clean
+
++TEST_PLUGINS=--cpufreq --disk-tps --dstat-cpu --dstat-ctxt --dstat-mem --dstat --helloworld --md-status --net-packets --proc-count --snooze --test --top-bio-adv --top-bio --top-childwait --top-cpu-adv --top-cpu --top-cputime-avg --top-cputime --top-int --top-io-adv --top-io --top-latency-avg --top-latency --top-mem --top-oom
++
+ test:
+ ./dstat --version
+ ./dstat -taf 1 5
+- ./dstat -t --all-plugins 1 5
++ ./dstat -t $(TEST_PLUGINS) 1 5
+
+ dist: clean
+ $(MAKE) -C docs dist