aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-12-27 10:56:33 +0000
committerPaul Healy <lmiphay@gmail.com>2017-12-27 10:56:33 +0000
commit5148355a835ad82e86188316aa25657ea4586bbf (patch)
tree594c9df0e96d09abd58e70140bf4cebde8b0fab8 /media-sound/pylms
parentadd dep on awscli (alternative lambda upload) (diff)
downloadlmiphay-5148355a835ad82e86188316aa25657ea4586bbf.tar.gz
lmiphay-5148355a835ad82e86188316aa25657ea4586bbf.tar.bz2
lmiphay-5148355a835ad82e86188316aa25657ea4586bbf.zip
add ebuild for pylms
Diffstat (limited to 'media-sound/pylms')
-rw-r--r--media-sound/pylms/Manifest1
-rw-r--r--media-sound/pylms/pylms-20170705.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/pylms/Manifest b/media-sound/pylms/Manifest
new file mode 100644
index 0000000..1a35378
--- /dev/null
+++ b/media-sound/pylms/Manifest
@@ -0,0 +1 @@
+EBUILD pylms-20170705.ebuild 701 SHA256 9e983c33d27b97ad64465e8a260950cb8c7170e616b1f7cd5bbded7f0ae73c42 SHA512 c8019d6e3ce4874ce10df5af5ce6940ef55cc2b93bd4bb36a6c351b001d08a7e7d0a34a0541387e95eab1f48fb225b6c52027e408814e2c13e69bcccaf8235f0 WHIRLPOOL 4d373507cd33b5653d41ed535f69cfdc77444e9497bc5eaa7bd78ef0e22057754793d600c225f4d34222b12a1558e17af3ff18336f7c7c305dc5f322f30002dc
diff --git a/media-sound/pylms/pylms-20170705.ebuild b/media-sound/pylms/pylms-20170705.ebuild
new file mode 100644
index 0000000..65f340c
--- /dev/null
+++ b/media-sound/pylms/pylms-20170705.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_{4,5,6})
+
+inherit eutils distutils-r1 git-r3
+
+DESCRIPTION="Logitech Media Server/Squeezebox API for Python"
+HOMEPAGE="https://github.com/jinglemansweep/PyLMS"
+EGIT_REPO_URI="https://github.com/jinglemansweep/PyLMS.git"
+EGIT_COMMIT="47694c67cb4971beb6896b804847f1f49ed79e26"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+DOCS="README.md docs/source"
+
+python_install() {
+ dodoc -r ${DOCS}
+ distutils-r1_python_install
+}