aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2020-04-17 13:56:16 +0100
committerPaul Healy <lmiphay@gmail.com>2020-04-17 13:56:16 +0100
commit39ea99cf5ab8fc84de1bb2cdaa007d188a814921 (patch)
tree885aba8bb5e415fdd90b93df22208b6798130b80 /dev-util
parentremove old ebuilds (diff)
downloadlmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.tar.gz
lmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.tar.bz2
lmiphay-39ea99cf5ab8fc84de1bb2cdaa007d188a814921.zip
revbump homeassistant
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/clion/clion-2019.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-util/clion/clion-2019.1.ebuild b/dev-util/clion/clion-2019.1.ebuild
deleted file mode 100644
index f6d25d7..0000000
--- a/dev-util/clion/clion-2019.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="http://www.jetbrains.com/clion"
-SRC_URI="http://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="IDEA
- || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
- dev-util/cmake
- sys-devel/gdb
- !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
- default
-
- local remove_me=(
- bin/gdb/linux
- bin/lldb/linux
- bin/cmake
- license/CMake*
- )
-
- use arm || remove_me+=( bin/fsnotifier-arm )
-
- use custom-jdk || remove_me+=( jre64 )
-
- rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
- local dir="/opt/${P}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{clion.sh,fsnotifier{,64},clang/linux/clang{d,-tidy}}
-
- if use custom-jdk; then
- if [[ -d jre64 ]]; then
- fperms 755 "${dir}"/jre64/bin/{java,jjs,keytool,orbd,pack200,policytool,rmid,rmiregistry,servertool,tnameserv,unpack200}
- fi
- fi
-
- make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
- newicon "bin/${PN}.svg" "${PN}.svg"
- make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- dodir /usr/lib/sysctl.d/
- echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}