aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-05-30 19:45:39 +0100
committerPaul Healy <lmiphay@gmail.com>2022-05-30 19:45:39 +0100
commit9bba9d1dc3c4d79de75a1a6340100818b39b791b (patch)
tree556505dbcc3c78dfed7e829152c439de485dd1be /app-oam
parentadd acct-group oam (diff)
downloadlmiphay-9bba9d1dc3c4d79de75a1a6340100818b39b791b.tar.gz
lmiphay-9bba9d1dc3c4d79de75a1a6340100818b39b791b.tar.bz2
lmiphay-9bba9d1dc3c4d79de75a1a6340100818b39b791b.zip
EAPI 8; add py3.11
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'app-oam')
-rw-r--r--app-oam/oam/Manifest2
-rw-r--r--app-oam/oam/oam-9999.ebuild13
2 files changed, 6 insertions, 9 deletions
diff --git a/app-oam/oam/Manifest b/app-oam/oam/Manifest
index f8beaa8..d89b3f6 100644
--- a/app-oam/oam/Manifest
+++ b/app-oam/oam/Manifest
@@ -1 +1 @@
-EBUILD oam-9999.ebuild 1785 BLAKE2B f664cb84798683488268adc05f04b17acb84fc5dfc8b80114ef4ca81d662e403800291b1a24552e045e5a268e93ce3bd4fa44d4eca5b71b8194648abd5b04637 SHA512 43d89cf49eb61e1fc28e5a0bd068072011311554d349459f10083a1248311ada3c37634f3ff5821894ac141738a4ec8fcdbec76ceb9e090a21d01058a29b5af3
+EBUILD oam-9999.ebuild 1765 BLAKE2B fd85ff6afbd335ce25b91a04598fb3dc78cff218ff4be9e5919597603407ad7395e429953e723ce358c0c019e8a91882b3fc9af77cc088c6f1549b7a472d59a4 SHA512 8beb9e26dffd6b0423dfc3d795d4be2d0d8c2ac03471683e901f229b663816ffc55ac9f5c864413a37aebb30c52572c9df779671126795fd24857f3bcc3774b2
diff --git a/app-oam/oam/oam-9999.ebuild b/app-oam/oam/oam-9999.ebuild
index 9ee6c5f..194cd20 100644
--- a/app-oam/oam/oam-9999.ebuild
+++ b/app-oam/oam/oam-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{9,10,11} )
DISTUTILS_USE_SETUPTOOLS=no
-inherit user distutils-r1 bash-completion-r1 git-r3
+inherit distutils-r1 bash-completion-r1 git-r3
DESCRIPTION="Operations and maintenance automation for gentoo servers"
HOMEPAGE="https://github.com/lmiphay/oam"
@@ -19,6 +19,7 @@ IUSE="+lnav +ranger server"
RDEPEND="
${PYTHON_DEPS}
+ acct-group/oam
app-admin/logrotate
app-portage/genlop
app-portage/gentoolkit
@@ -44,10 +45,6 @@ DEPEND="
DOCS="README.md"
-pkg_setup() {
- enewgroup oam
-}
-
python_install_all() {
dodoc ${DOCS}
newbashcomp etc/bash.completion oam