aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-04-21 17:45:14 +0100
committerPaul Healy <lmiphay@gmail.com>2019-04-21 17:45:14 +0100
commit44ed69484c34caf05d4a4aa904fdd1b1ff76286e (patch)
tree19b5e758564aab5abb81c39ac71ee5c5c8314bd6 /app-homeassistant
parentadd app-homeassistant category (diff)
downloadlmiphay-44ed69484c34caf05d4a4aa904fdd1b1ff76286e.tar.gz
lmiphay-44ed69484c34caf05d4a4aa904fdd1b1ff76286e.tar.bz2
lmiphay-44ed69484c34caf05d4a4aa904fdd1b1ff76286e.zip
add ebuild for simple-thermostat
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'app-homeassistant')
-rw-r--r--app-homeassistant/simple-thermostat/Manifest2
-rw-r--r--app-homeassistant/simple-thermostat/simple-thermostat-0.21.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/app-homeassistant/simple-thermostat/Manifest b/app-homeassistant/simple-thermostat/Manifest
new file mode 100644
index 0000000..4a9a186
--- /dev/null
+++ b/app-homeassistant/simple-thermostat/Manifest
@@ -0,0 +1,2 @@
+DIST simple-thermostat-0.21.0.js 31213 BLAKE2B 70902bdc284629257041c10ba2cb7992cb159e58e1c5f79c54e34eb2fe988d98387d104694f401a5016364560bc4ec0c374c358bded3ac982be6e19d1b301d0a SHA512 ad77c17b24680711746f2a7cb78462b5c7abde9e1c4f5972dd6657cf64f3ad8de60f3358bf8235af14744399770b9152a28e46e843ee6222336e3e1f2a5dde84
+EBUILD simple-thermostat-0.21.0.ebuild 871 BLAKE2B 5b89f4de183175d5a2e5b1db3f4f55aa78f32a7ba82178298370fe8a4326a3e9ec1e319703c1f982ee9312d18a7a588c98331812024694a87f8e88e879baa96e SHA512 cd16607ec8f9fa34c043441c0006395c36e63d0f4d6cd1e9a7f64a6b91ab3557d7651e97103bc041bb7b154b4fb82b0f2275bd92e4d6563b2f67e38ad6901b4b
diff --git a/app-homeassistant/simple-thermostat/simple-thermostat-0.21.0.ebuild b/app-homeassistant/simple-thermostat/simple-thermostat-0.21.0.ebuild
new file mode 100644
index 0000000..935c843
--- /dev/null
+++ b/app-homeassistant/simple-thermostat/simple-thermostat-0.21.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="A different take on the thermostat card for Home Assistant Lovelace UI"
+HOMEPAGE="https://github.com/nervetattoo/simple-thermostat"
+SRC_URI="https://github.com/nervetattoo/simple-thermostat/releases/download/${PV}/${PN}.js -> ${P}.js"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-misc/homeassistant-bin"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}"
+
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+DOC_CONTENTS="
+ To configure Lovelace to load the simple-thermostat card, see:
+
+ https://github.com/nervetattoo/simple-thermostat#installation-manual
+"
+
+src_install() {
+ insinto /etc/homeassistant/www
+ newins "${P}.js" "${PN}.js"
+
+ readme.gentoo_create_doc
+ default
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}