summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-02-01 19:11:41 +0100
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-02-01 19:11:41 +0100
commitf14923f780e6270143e2b32bedaf117e5318361e (patch)
tree5a0419a892bc1c333d7a38e04f0b679ead0b8bfc
parentsys-devel/redo-0.05: Version bump (diff)
downloadkork-f14923f780e6270143e2b32bedaf117e5318361e.tar.gz
kork-f14923f780e6270143e2b32bedaf117e5318361e.tar.bz2
kork-f14923f780e6270143e2b32bedaf117e5318361e.zip
app-backup/bup "edelic" 0.22: now with "dumb server" mode
-rw-r--r--app-backup/bup/Manifest6
-rw-r--r--app-backup/bup/bup-0.22.ebuild (renamed from app-backup/bup/bup-0.20.ebuild)13
-rw-r--r--app-backup/bup/bup-9999.ebuild4
3 files changed, 12 insertions, 11 deletions
diff --git a/app-backup/bup/Manifest b/app-backup/bup/Manifest
index 26b1f64..421e1d3 100644
--- a/app-backup/bup/Manifest
+++ b/app-backup/bup/Manifest
@@ -1,5 +1,5 @@
-DIST bup-0.20.tar.gz 305377 RMD160 8f3044e1708298b6b6ac9189a7101b261ba4de7f SHA1 38b26cae2f7336c6400cd732854edf1b3bdbb5fb SHA256 44f6f9bad1ace63b6369eda7c3bf4e696d61b61196f923688cb3754b83a9f165
DIST bup-0.21.tar.gz 311728 RMD160 d74b328e14c03b83763738b0274039da51a9d6b7 SHA1 57c251452da74f0905e2eca0d4c5063442d52b88 SHA256 cb5d27cb0297fdb7ee8ddc6e9b87bec6171469148cf62877d970011e47c75d60
-EBUILD bup-0.20.ebuild 944 RMD160 abc1623193b3c50a837c0c99e2cabc757d001891 SHA1 5fe6cebd02713caf5eb7c6607080ffbdd63375b1 SHA256 c54049e5abd39abf0685b817fca6aba536551288844b06c25ea17c971ca94b9d
+DIST bup-0.22.tar.gz 316882 RMD160 d7e0ea6a2954fad6af2a20315ff9eaf6a2ccb181 SHA1 a9ea12579ee25a03bdb2888addaefc17fd153810 SHA256 38412ade9403ad36c03c1506ad87d66c15d4ff706b8e6c2fdf02b256487f13d5
EBUILD bup-0.21.ebuild 937 RMD160 17768fc4714853359a255df4d518cb969a70918b SHA1 c50ad176279bdbef6ca8bd28f1de8184e0501aaf SHA256 0cb5fa01a9945e314f4639aa3c1ba71c05ae777d4fde56f9ac3987e9a1ae896e
-EBUILD bup-9999.ebuild 851 RMD160 0271aea3d9b6ca93c75388226c65c5085594b412 SHA1 a8195dea047e8e01d0bac5591c50bc21608ba998 SHA256 34e6f4f78d28dc41335fc54d98909918369e2973661e336a3552c6437ac38569
+EBUILD bup-0.22.ebuild 937 RMD160 17768fc4714853359a255df4d518cb969a70918b SHA1 c50ad176279bdbef6ca8bd28f1de8184e0501aaf SHA256 0cb5fa01a9945e314f4639aa3c1ba71c05ae777d4fde56f9ac3987e9a1ae896e
+EBUILD bup-9999.ebuild 851 RMD160 506c1337a76757acd17893db0395e912f792e830 SHA1 499ebcf153559860b7d7bb9ad90e272620daeafd SHA256 980181ad752fac7f4f76dec40237fc02941b51bdafa62cc3d664df15f98a393b
diff --git a/app-backup/bup/bup-0.20.ebuild b/app-backup/bup/bup-0.22.ebuild
index 052cfc6..0952e81 100644
--- a/app-backup/bup/bup-0.20.ebuild
+++ b/app-backup/bup/bup-0.22.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=3
inherit eutils
-UNPACKDIR="apenwarr-${PN}-aa66cef"
-
DESCRIPTION="It backs things up based on the git packfile format"
HOMEPAGE="http://github.com/apenwarr/bup"
-SRC_URI="https://github.com/apenwarr/${PN}/tarball/${P} -> ${P}.tar.gz"
+SRC_URI="https://github.com/apenwarr/${PN}/tarball/${P/_/-} -> ${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
@@ -28,7 +26,10 @@ DEPEND="|| (
doc? ( app-text/pandoc )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${UNPACKDIR}"
+src_unpack() {
+ unpack ${A}
+ mv -v * "${S}" || die
+}
src_compile() {
emake || die "emake failed"
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
index 63732e4..7c4e92b 100644
--- a/app-backup/bup/bup-9999.ebuild
+++ b/app-backup/bup/bup-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=3
inherit git eutils
DESCRIPTION="It backs things up based on the git packfile format"