summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/i2pd/i2pd-9999.ebuild')
-rw-r--r--net-misc/i2pd/i2pd-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-misc/i2pd/i2pd-9999.ebuild b/net-misc/i2pd/i2pd-9999.ebuild
index 61577b2..14ed608 100644
--- a/net-misc/i2pd/i2pd-9999.ebuild
+++ b/net-misc/i2pd/i2pd-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -39,11 +39,15 @@ multilib_src_configure() {
$(multilib_is_native_abi && echo -DWITH_BINARY=ON \
|| echo -DWITH_BINARY=OFF)
)
- cmake-utils_src_configure
+ (multilib_is_native_abi || use library) && cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ (multilib_is_native_abi || use library) && cmake-utils_src_compile
}
multilib_src_install() {
- cmake-utils_src_install
+ (multilib_is_native_abi || use library) && cmake-utils_src_install
}
multilib_src_install_all() {