summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-05-31 15:05:17 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-05-31 15:05:17 +0200
commit0bf6ca5a599976344140eba616ee3430122cff6e (patch)
treeefd680bafea87d08676903cf6473d7d51d9901da /games-action
parentfix clutter include (diff)
downloadkeruspe-0bf6ca5a599976344140eba616ee3430122cff6e.tar.gz
keruspe-0bf6ca5a599976344140eba616ee3430122cff6e.tar.bz2
keruspe-0bf6ca5a599976344140eba616ee3430122cff6e.zip
add student project
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bomb-her-man/Manifest1
-rw-r--r--games-action/bomb-her-man/bomb-her-man-9999.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/games-action/bomb-her-man/Manifest b/games-action/bomb-her-man/Manifest
new file mode 100644
index 00000000..690c38ea
--- /dev/null
+++ b/games-action/bomb-her-man/Manifest
@@ -0,0 +1 @@
+EBUILD bomb-her-man-9999.ebuild 645 RMD160 26ac55adb4f083f7e81bc527ab378299f019f3e1 SHA1 ae64eb67eef8147806c4ef6ff4d796799ef0db51 SHA256 4f11fff564a56fd5e2d636ec525811c79eae2d00988c53b34a063592dc92d449
diff --git a/games-action/bomb-her-man/bomb-her-man-9999.ebuild b/games-action/bomb-her-man/bomb-her-man-9999.ebuild
new file mode 100644
index 00000000..007b1c52
--- /dev/null
+++ b/games-action/bomb-her-man/bomb-her-man-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit games git
+
+DESCRIPTION="A bomberman clone, student project for SUPINFO, France"
+HOMEPAGE="http://github.com/Keruspe/Bomb-her-man"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/Keruspe/Bomb-her-man.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="media-libs/sdl-ttf
+ x11-libs/cairo
+ gnome-base/librsvg
+ doc? ( app-doc/doxygen )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+ use doc && emake DESTDIR=${D} install-doc
+}