summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-02-08 15:51:46 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-02-08 15:51:46 +0100
commiteb42b1f11e03327e7ea5944b8645901a26dae41d (patch)
treeb32c1e1c27ee74e9c5933e601704627087a6655e
parentupdate systemd (diff)
downloadkeruspe-eb42b1f11e03327e7ea5944b8645901a26dae41d.tar.gz
keruspe-eb42b1f11e03327e7ea5944b8645901a26dae41d.tar.bz2
keruspe-eb42b1f11e03327e7ea5944b8645901a26dae41d.zip
fix systemd
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild30
2 files changed, 20 insertions, 12 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index eed75c32..1efa1d89 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1 +1 @@
-EBUILD systemd-9999.ebuild 4375 RMD160 6eb0bad5667195f35847ff6eee0bdd8b294ffe35 SHA1 a83811c2e1519775885e110847083034a7e84bec SHA256 a009e06b4749394fd4e887ee8248476257eb6c1de24b1b9c774c162b5ae5004c
+EBUILD systemd-9999.ebuild 4707 RMD160 6591e560800f1e8fba95c11f5b6bb4243d04ad9c SHA1 271cc01b26b6d4e09c5ffb93162f27565fbfbdb3 SHA256 e8fc7a2c2a8f41a7284e782b3ff4595fa79cae281563f1f01d995d4c3d8b2471
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 54c6109f..d585427f 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -14,7 +14,7 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="acl audit cryptsetup gtk +pam python plymouth selinux symlinks +tcpd"
+IUSE="acl audit cryptsetup gtk lzma +pam python plymouth selinux symlinks +tcpd"
COMMON_DEPEND=">=sys-apps/dbus-1.4.10
>=sys-apps/util-linux-2.19
@@ -26,8 +26,10 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.10
gtk? (
dev-libs/dbus-glib
>=dev-libs/glib-2.26
+ dev-libs/libgee:0
x11-libs/gtk+:2
>=x11-libs/libnotify-0.7 )
+ lzma? ( app-arch/xz-utils )
pam? ( virtual/pam )
python? ( dev-python/dbus-python
dev-python/pycairo )
@@ -52,6 +54,7 @@ RDEPEND="${COMMON_DEPEND}
sys-apps/systemd-units
!<sys-apps/openrc-0.8.3"
DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
dev-util/gperf
dev-util/intltool
dev-lang/vala:${VALASLOT}
@@ -72,20 +75,24 @@ src_prepare() {
}
src_configure() {
- local myeconfargs="
+ local myeconfargs=(
--with-distro=gentoo
- --with-rootdir=
+ # install everything to /usr
+ --with-rootprefix=/usr
--with-rootlibdir=/usr/$(get_libdir)
+ # but pam modules have to lie in /lib*
+ --with-pamlibdir=/$(get_libdir)/security
--localstatedir=/var
$(use_enable acl)
$(use_enable audit)
$(use_enable cryptsetup libcryptsetup)
$(use_enable gtk)
+ $(use_enable lzma xz)
$(use_enable pam)
$(use_enable plymouth)
$(use_enable selinux)
$(use_enable tcpd tcpwrap)
- "
+ )
if use gtk; then
export VALAC="$(type -p valac-${VALASLOT})"
@@ -102,11 +109,11 @@ rename_mans() {
}
do_symlinks() {
- dosym /bin/systemctl /sbin/init
- dosym /bin/systemctl /sbin/poweroff
- dosym /bin/systemctl /sbin/halt
- dosym /bin/systemctl /sbin/reboot
- dosym /bin/systemctl /sbin/shutdown
+ dosym /usr/bin/systemctl /sbin/init
+ dosym /usr/bin/systemctl /sbin/poweroff
+ dosym /usr/bin/systemctl /sbin/halt
+ dosym /usr/bin/systemctl /sbin/reboot
+ dosym /usr/bin/systemctl /sbin/shutdown
}
src_install() {
@@ -132,11 +139,12 @@ pkg_preinst() {
}
optfeature() {
- elog " [$(has_version ${1} && echo I || echo ' ')] ${1} (${2})"
+ elog " [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1} (${2})"
}
pkg_postinst() {
- if [[ ! -L "${ROOT}"etc/mtab ]]; then
+ mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."
+ if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
ewarn "require that specific feature, please call:"