summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-10-21 12:10:06 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-10-21 12:10:06 +0200
commita2fa49ccbdfada6f7350583af16a9ca64f4a9268 (patch)
tree49c7ff89af6c3c91ca074484a0892e6d2efdce88
parentfix gdm (diff)
downloadkeruspe-a2fa49ccbdfada6f7350583af16a9ca64f4a9268.tar.gz
keruspe-a2fa49ccbdfada6f7350583af16a9ca64f4a9268.tar.bz2
keruspe-a2fa49ccbdfada6f7350583af16a9ca64f4a9268.zip
fix gnome-bluetooth
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--net-wireless/gnome-bluetooth/Manifest2
-rw-r--r--net-wireless/gnome-bluetooth/files/80-rfkill.rules5
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild100
-rw-r--r--profiles/categories1
4 files changed, 108 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
new file mode 100644
index 00000000..0ccac3f4
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -0,0 +1,2 @@
+AUX 80-rfkill.rules 117 RMD160 78e948840a4359344d3bd565300e4432fe43bf91 SHA1 6a6b28aaf852aae9e419963ddbdb92092825f4ee SHA256 81b3a8a3a3639b6d6024043364ad4917b32a85fd7f766e4051211d388e165798
+EBUILD gnome-bluetooth-9999.ebuild 2393 RMD160 b1c6ca91be77de656f1044e2cae671ab7784a0fa SHA1 24cefe7276e108c697d7c1c5618424b295868771 SHA256 e83e672ea67543bc7de9cdeb00d6ff02166961e74afc940369c840b98c7453c0
diff --git a/net-wireless/gnome-bluetooth/files/80-rfkill.rules b/net-wireless/gnome-bluetooth/files/80-rfkill.rules
new file mode 100644
index 00000000..61f9ca5e
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/80-rfkill.rules
@@ -0,0 +1,5 @@
+# do not edit this file, it will be overwritten on update
+
+# network
+KERNEL=="rfkill", GROUP="plugdev", MODE="0664"
+
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild
new file mode 100644
index 00000000..9621d87d
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+# libgnome-bluetooth-applet.la is needed by gnome-shell during compilation
+GNOME2_LA_PUNT="no"
+
+inherit gnome2 multilib
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+IUSE="doc +introspection sendto"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+COMMON_DEPEND=">=dev-libs/glib-2.25.7:2
+ >=x11-libs/gtk+-2.91.3:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+ >=dev-libs/dbus-glib-0.74
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ sendto? ( >=gnome-extra/nautilus-sendto-2.91 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd
+ sys-fs/udev"
+# To break circular dependencies
+PDEPEND=">=gnome-base/gnome-control-center-2.91"
+DEPEND="${COMMON_DEPEND}
+ !!net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ # FIXME: Add geoclue support
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_enable sendto nautilus-sendto)
+ --disable-maintainer-mode
+ --disable-moblin
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-schemas-compile
+ --disable-static"
+ DOCS="AUTHORS README NEWS ChangeLog"
+
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Add missing files for intltool checks
+ echo "sendto/bluetooth-sendto.desktop.in" >> po/POTFILES.in
+ echo "wizard/bluetooth-wizard.desktop.in" >> po/POTFILES.in
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ local la
+ for la in gnome-bluetooth/plugins/libgbtgeoclue.la \
+ libgnome-bluetooth.la; do
+ rm -v "${ED}/usr/$(get_libdir)/${la}" || die
+ done
+
+ insinto /$(get_libdir)/udev/rules.d
+ doins "${FILESDIR}"/80-rfkill.rules || die "udev rules installation failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+}
diff --git a/profiles/categories b/profiles/categories
index b74236fa..8095dafb 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -19,6 +19,7 @@ net-im
net-libs
net-misc
net-voip
+net-wireless
sys-apps
x11-libs
x11-misc