summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-14 12:20:59 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-14 12:26:58 +0100
commit473c451f3116625cc727d9051e8bb80f5666f1fc (patch)
tree2a88d49dfcc6ab503ca2243a52c49af08816e0e4
parentsystemd: rename bash completion (diff)
downloadkeruspe-473c451f3116625cc727d9051e8bb80f5666f1fc.tar.gz
keruspe-473c451f3116625cc727d9051e8bb80f5666f1fc.tar.bz2
keruspe-473c451f3116625cc727d9051e8bb80f5666f1fc.zip
ad gnome-bluetooth
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--net-wireless/gnome-bluetooth/Manifest2
-rw-r--r--net-wireless/gnome-bluetooth/files/80-rfkill.rules5
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-9999-r1.ebuild85
-rw-r--r--profiles/categories1
4 files changed, 93 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
new file mode 100644
index 00000000..92f1bb13
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -0,0 +1,2 @@
+AUX 80-rfkill.rules 117 RMD160 78e948840a4359344d3bd565300e4432fe43bf91 SHA1 6a6b28aaf852aae9e419963ddbdb92092825f4ee SHA256 81b3a8a3a3639b6d6024043364ad4917b32a85fd7f766e4051211d388e165798
+EBUILD gnome-bluetooth-9999-r1.ebuild 2030 RMD160 775bb40bb134f2fd4e94824642348833970a184d SHA1 fbe3e5c3c3c0058805d5cd61f236592f2a91d19c SHA256 2ccf9238a01d156004ab7c6d3a95ba9dbaea950d43c04f77078c3eb7c4e0b29d
diff --git a/net-wireless/gnome-bluetooth/files/80-rfkill.rules b/net-wireless/gnome-bluetooth/files/80-rfkill.rules
new file mode 100644
index 00000000..61f9ca5e
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/80-rfkill.rules
@@ -0,0 +1,5 @@
+# do not edit this file, it will be overwritten on update
+
+# network
+KERNEL=="rfkill", GROUP="plugdev", MODE="0664"
+
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-9999-r1.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999-r1.ebuild
new file mode 100644
index 00000000..b2df2c8c
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-9999-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2-live multilib
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+IUSE="doc +introspection sendto"
+KEYWORDS=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.25.7:2
+ >=x11-libs/gtk+-2.91.3:3[introspection?]
+ >=x11-libs/libnotify-0.7.0
+ >=dev-libs/dbus-glib-0.74
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ sendto? ( >=gnome-extra/nautilus-sendto-2.91 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd
+ sys-fs/udev"
+# To break circular dependencies
+PDEPEND=">=gnome-base/gnome-control-center-2.91"
+DEPEND="${COMMON_DEPEND}
+ !!net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+# eautoreconf needs:
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ # FIXME: Add geoclue support
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_enable sendto nautilus-sendto)
+ --disable-moblin
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-schemas-compile
+ --disable-static"
+ DOCS="AUTHORS README NEWS ChangeLog"
+
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Add missing files for intltool checks
+ echo "sendto/bluetooth-sendto.desktop.in" >> po/POTFILES.in
+ echo "wizard/bluetooth-wizard.desktop.in" >> po/POTFILES.in
+
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /$(get_libdir)/udev/rules.d
+ doins "${FILESDIR}"/80-rfkill.rules || die "udev rules installation failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+}
diff --git a/profiles/categories b/profiles/categories
index 93d2ed3f..b6ead8b5 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -19,6 +19,7 @@ net-im
net-libs
net-misc
net-voip
+net-wireless
sys-apps
x11-libs
x11-misc