summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-06 17:43:32 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-06 17:43:32 +0100
commit3c5e03fced28dbacf6a2c4c294edcd23dae95f77 (patch)
tree3f991267dc7fed7d9e25f1e9146ad2026dbdd738
parentudpate moar ebuilds (diff)
downloadkeruspe-3c5e03fced28dbacf6a2c4c294edcd23dae95f77.tar.gz
keruspe-3c5e03fced28dbacf6a2c4c294edcd23dae95f77.tar.bz2
keruspe-3c5e03fced28dbacf6a2c4c294edcd23dae95f77.zip
missing patch
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--dev-libs/glib/Manifest1
-rw-r--r--dev-libs/glib/files/glib-2.30.1-homedir-env.patch61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/glib/Manifest b/dev-libs/glib/Manifest
index bbde2b68..48c3d4b5 100644
--- a/dev-libs/glib/Manifest
+++ b/dev-libs/glib/Manifest
@@ -2,5 +2,6 @@ AUX external-gdbus-codegen.patch 3612 RMD160 506da8f95bad3d7e8dd8a003cc392eb9b66
AUX glib-2.12.12-fbsd.patch 668 RMD160 d8bf399b7e0b417c4622b278282086418c1d3363 SHA1 b7a0f4d67083f2c9b4bbecd84a6d597dd0f0f9ed SHA256 23b0dc406d3d45fe125268b731af67147e83f6e38a63c7892828bdbfe1c31e8d
AUX glib-2.18.1-workaround-gio-test-failure-without-userpriv.patch 616 RMD160 dd06abe9298d6e3e4d3eda0d5d155f1545dfd1aa SHA1 92164aa1b29f49cf62fc366231f2046b8b3def52 SHA256 e64ad4fbd67f142f5a19b29eab323bf18856309ed064e7a9f838b6c1c38a8adb
AUX glib-2.24-assert-test-failure.patch 724 RMD160 011da2b341281d14741e715eddd401968464608d SHA1 76149f52677a337569dbab1b5f664c8fc16d44ff SHA256 1e3d290455d6bbc3a4f69d7b8abdeb559a01c8cd30dc311641e1cb0b7f84c6af
+AUX glib-2.30.1-homedir-env.patch 1849 RMD160 2bbe190e2d6ee96cb33dcfe37c1ff227ea4e8ca9 SHA1 42077f9373acce576b4eb811b6464f0332db7711 SHA256 4f0e149703a9aadc4fb568b9fa00419b9848b345b19d3cc9e1a2bd67985ea25b
DIST pkg-config-0.26.tar.gz 396399 RMD160 face3d16ec338b9b1ab41d56d6e4d1a5624b52d0 SHA1 fd71a70b023b9087c8a7bb76a0dc135a61059652 SHA256 94c1936a797c930fb3e4e5a154165b6268caba22b32d24083dd4c492a533c8af
EBUILD glib-9999-r1.ebuild 7992 RMD160 f832910aba302f8466e1e5db5ed0184db7ad4cad SHA1 5a7e47f914e4ef4b31c0d4afc0d24a5f6ac90bbf SHA256 61c0e40c11dac78a8281ccdb0eb91f8bb98189b35dc091fe6fa3e047eb80300d
diff --git a/dev-libs/glib/files/glib-2.30.1-homedir-env.patch b/dev-libs/glib/files/glib-2.30.1-homedir-env.patch
new file mode 100644
index 00000000..30d44997
--- /dev/null
+++ b/dev-libs/glib/files/glib-2.30.1-homedir-env.patch
@@ -0,0 +1,61 @@
+Description: Handle the G_HOME environment variable to override the passwd entry
+ This will allow to fix various kinds of build failures due to restricted
+ build environments.
+Author: Josselin Mouette <joss@debian.org>
+Origin: vendor
+
+--- a/docs/reference/glib/running.sgml
++++ b/docs/reference/glib/running.sgml
+@@ -213,6 +213,22 @@
+ </para>
+ </formalpara>
+
++<formalpara id="G_HOME">
++ <title><envar>G_HOME</envar></title>
++
++ <para>
++ For various reasons, GLib applications ignore the <envar>HOME</envar>
++ environment variable on Unix systems and will use the user directory
++ as specified by the <filename>passwd</filename> entry, which is more
++ reliable.
++ </para>
++ <para>
++ The <envar>G_HOME</envar> environment variable will override any
++ other setting for the home directory. It is not meant for daily usage,
++ but it is useful in testing or building environments.
++ </para>
++</formalpara>
++
+ </refsect2>
+
+ <refsect2 id="setlocale">
+--- a/glib/gutils.c
++++ b/glib/gutils.c
+@@ -1626,11 +1626,14 @@
+ }
+ #endif /* !G_OS_WIN32 */
+
++ g_home_dir = g_strdup (g_getenv ("G_HOME"));
++
+ #ifdef G_OS_WIN32
+ /* We check $HOME first for Win32, though it is a last resort for Unix
+ * where we prefer the results of getpwuid().
+ */
+- g_home_dir = g_strdup (g_getenv ("HOME"));
++ if (!g_home_dir)
++ g_home_dir = g_strdup (g_getenv ("HOME"));
+
+ /* Only believe HOME if it is an absolute path and exists */
+ if (g_home_dir)
+@@ -1926,6 +1929,11 @@
+ * homedir = g_get_home_dir (<!-- -->);
+ * ]|
+ *
++ * However, to allow changing this value for testing and development
++ * purposes, the value of the <envar>G_HOME</envar> environment
++ * variable, if set, will override the <filename>passwd</filename>
++ * entry.
++ *
+ * Returns: the current user's home directory
+ */
+ G_CONST_RETURN gchar*