summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaroslav Hron <jaroslav.hron@gmail.com>2011-08-11 11:39:49 +0200
committerJaroslav Hron <jaroslav.hron@gmail.com>2011-08-11 11:39:49 +0200
commitedf24aa16c45fd703a1552613e3134fa47639227 (patch)
tree14619557a5d9d083e079cf657f1358af0303c467 /net-misc
parentset repo name (diff)
downloadjxh-edf24aa16c45fd703a1552613e3134fa47639227.tar.gz
jxh-edf24aa16c45fd703a1552613e3134fa47639227.tar.bz2
jxh-edf24aa16c45fd703a1552613e3134fa47639227.zip
initial check-in
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/remmina/Manifest5
-rw-r--r--net-misc/remmina/remmina-0.7.3.ebuild43
-rw-r--r--net-misc/remmina/remmina-0.7.4.ebuild43
-rw-r--r--net-misc/unison/Manifest13
-rw-r--r--net-misc/unison/files/unison-2.27.57-as-needed.patch11
-rw-r--r--net-misc/unison/files/unison-2.40.61-makefile.patch12
-rw-r--r--net-misc/unison/files/unison-mymap.patch13
-rw-r--r--net-misc/unison/unison-2.40.16.ebuild87
-rw-r--r--net-misc/unison/unison-2.40.61.ebuild88
9 files changed, 315 insertions, 0 deletions
diff --git a/net-misc/remmina/Manifest b/net-misc/remmina/Manifest
new file mode 100644
index 0000000..fe99525
--- /dev/null
+++ b/net-misc/remmina/Manifest
@@ -0,0 +1,5 @@
+DIST remmina-0.7.3.tar.gz 622850 RMD160 f340b1eb3959bb38bc7221bdf1a3c2c43a2b0a19 SHA1 014c121fe1930166330afe5dc30aa6317f5fa6a3 SHA256 2d36a747944f37fa01f4697595d39f120137c1a15e6ed7b3fa6de43fb5957d25
+DIST remmina-0.7.4.tar.gz 626240 RMD160 2d8a0d63400436d1f2a262c16b164394244e7e09 SHA1 77c15424abba9ee1934d48b887220fc49aafeecc SHA256 852bfe376282c5e51b5fe6255e7ab279e2d2314bad6e792fbf71c40266ddb153
+EBUILD remmina-0.7.3.ebuild 906 RMD160 6cafe4d401abba68c1f1267aef258c1f80e71155 SHA1 5f4eb3bbcaabf866770c49887acba11f43c04a0b SHA256 9bc646e3a5da5f82cc8244ba6f742a90d0b76b2d9df6569fd34f9864a82a6e05
+EBUILD remmina-0.7.4.ebuild 906 RMD160 6cafe4d401abba68c1f1267aef258c1f80e71155 SHA1 5f4eb3bbcaabf866770c49887acba11f43c04a0b SHA256 9bc646e3a5da5f82cc8244ba6f742a90d0b76b2d9df6569fd34f9864a82a6e05
+MISC remmina-0.7.3.ebuild~ 868 RMD160 2d41882b91b190450fb50152b6e0b958074ae597 SHA1 f1aab1ddf26de5c808a289bfa3c89ab3225eafa1 SHA256 95765be7b5dfa3809d662d1b48a0e082c0883568d8e070dfa5c55d60fb5f8d59
diff --git a/net-misc/remmina/remmina-0.7.3.ebuild b/net-misc/remmina/remmina-0.7.3.ebuild
new file mode 100644
index 0000000..ea1bc83
--- /dev/null
+++ b/net-misc/remmina/remmina-0.7.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit autotools gnome2 eutils
+
+DESCRIPTION="Gtk+/GNOME Remote Desktop Client"
+HOMEPAGE="http://remmina.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="avahi ssh vnc"
+
+RDEPEND=">=x11-libs/gtk+-2.16
+ >=dev-libs/glib-2.20
+ net-misc/rdesktop
+ >=dev-libs/libgcrypt-1.4.0
+ >=dev-libs/libunique-1.0.8
+ >=x11-libs/vte-0.12
+ avahi? ( >=net-dns/avahi-0.6.2[gtk,dbus] )
+ ssh? ( net-misc/openssh
+ >=net-libs/libssh-0.4 )
+ vnc? ( net-misc/tigervnc
+ sys-libs/zlib
+ media-libs/jpeg
+ >=net-libs/gnutls-2.4 )"
+
+DEPEND="${RDEPEND}"
+
+docs="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable avahi)
+ $(use_enable ssh)
+ $(use_enable vnc)
+ --enable-gcrypt --enable-vte"
+}
diff --git a/net-misc/remmina/remmina-0.7.4.ebuild b/net-misc/remmina/remmina-0.7.4.ebuild
new file mode 100644
index 0000000..ea1bc83
--- /dev/null
+++ b/net-misc/remmina/remmina-0.7.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit autotools gnome2 eutils
+
+DESCRIPTION="Gtk+/GNOME Remote Desktop Client"
+HOMEPAGE="http://remmina.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="avahi ssh vnc"
+
+RDEPEND=">=x11-libs/gtk+-2.16
+ >=dev-libs/glib-2.20
+ net-misc/rdesktop
+ >=dev-libs/libgcrypt-1.4.0
+ >=dev-libs/libunique-1.0.8
+ >=x11-libs/vte-0.12
+ avahi? ( >=net-dns/avahi-0.6.2[gtk,dbus] )
+ ssh? ( net-misc/openssh
+ >=net-libs/libssh-0.4 )
+ vnc? ( net-misc/tigervnc
+ sys-libs/zlib
+ media-libs/jpeg
+ >=net-libs/gnutls-2.4 )"
+
+DEPEND="${RDEPEND}"
+
+docs="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable avahi)
+ $(use_enable ssh)
+ $(use_enable vnc)
+ --enable-gcrypt --enable-vte"
+}
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
new file mode 100644
index 0000000..a9b1232
--- /dev/null
+++ b/net-misc/unison/Manifest
@@ -0,0 +1,13 @@
+AUX unison-2.27.57-as-needed.patch 432 RMD160 a6b5baf799f686764c7dc9285541cae9178c4fbd SHA1 f7566f358355b0ecb5e000101721d189363bbdc4 SHA256 0284d72f0d9de0a824c2bc2a2f78baced3b84eb15ea10e0e6576ff52cf57686d
+AUX unison-2.40.61-makefile.patch 523 RMD160 3ba6449ecddac57a91af646872b8de1fc88be16d SHA1 7329df33f09aa736991707f12c2bcc749bbaf5f1 SHA256 677f1380e5916c5c37ee17b022819d2013f02b3a6272ea8244484ac9b5941f08
+AUX unison-mymap.patch 466 RMD160 b317f3a79f11c2f9a91afa9801d196e8981f833b SHA1 5cc693b6bb2252a220b7db47227dd55cb0a7350e SHA256 1b73b9b4cf308b2f538fddfe95ee2ae42f5090015fbce132d2ae5789ea25a480
+DIST unison-2.40.16-manual.html 267159 RMD160 6b278d60711b3e7ac17b99a3f91bb3407d1cac8b SHA1 93958405ee07474ef9f1872ad8672fd884e84c34 SHA256 ffe6c85057ae8f8dcd76a02e2dfd1b37aa4681bc968f3be8945503547f038398
+DIST unison-2.40.16-manual.pdf 507350 RMD160 7b693ed1ad5507f0b88c5a21270c9a51193a9cfb SHA1 63733442a0f4538a7179d77001a04404574e58b3 SHA256 e49dcb0715152299fce11539c2d532bd4da9a4bb8af98670f8c61b6a13e241fe
+DIST unison-2.40.16.tar.gz 2712897 RMD160 b6a7c3fb8cd30b96352ea3a3cdcdb566ad9c52aa SHA1 148b2b617f18743128ba978b1cadad05624ce22c SHA256 7307824ec50507cc796608ae1da1bfa01216f0e7140e1a7344b325c7354b59b0
+DIST unison-2.40.61-manual.html 267159 RMD160 ba193743e36bdd868f9576610b94e59e7baf8cb8 SHA1 b941d7a40d1e9968d72ead4d61375091a28c9028 SHA256 b88c6c3a24c359e306e702672cc8da904e72c367861ef2a3dc3df07566948223
+DIST unison-2.40.61-manual.pdf 507350 RMD160 5fa0283fcf68849313214270698c27edd5b2aa41 SHA1 1410adf5edaf4be22598550dbfae5f861b440586 SHA256 75ff6909abcf6f9ea0a981a8e3827218491fcdfb03c088c8dd1e43fcc9c687ef
+DIST unison-2.40.61.tar.gz 2702722 RMD160 4a0bcc636d0e182be13723a5d9c676406824f638 SHA1 8645ce93a525b9561d51cceb9c4f9f08cea650e9 SHA256 e6114bf6a99d8bbe151250b7e28a74aa546d213f4f7f7914ca086a48b375277b
+EBUILD unison-2.40.16.ebuild 2505 RMD160 e27e364ce131a0a01f5cf132cb3b3cfdc76a7d89 SHA1 9f0b74b304aaabdbb816e871926388b16f9585d0 SHA256 0021cdb06755170a751195a17ccff1170efb7e55a66ca49eef767cf02565616d
+EBUILD unison-2.40.61.ebuild 2557 RMD160 6d2631b81ff5af20d3b1b55d48f17e9a2784dc93 SHA1 b45661c555a024c83e67ae3e40cc4cc263fb85c6 SHA256 8f7edf3ebb2636adacde6c963ecb83b490c50b858ffae63e4904ed8984b13ef8
+MISC unison-2.40.16.ebuild~ 2504 RMD160 bfeacb7069e2a15495a4308f191ed3a1ddd4b1c6 SHA1 0e6b6b32cf8f4352755fc4c1b04f85c7b98e9764 SHA256 c4ec7bbbedc42318a00e0c8521d6882c51d7a9fa1b47c59b39b883d2d7843436
+MISC unison-2.40.61.ebuild~ 2508 RMD160 257e0396f1caf90079d4f3a2b6de455eda021902 SHA1 d65b780dc71caf41de9bef92f707293c9601a9bd SHA256 46f6db43fe7bfca7d08cd5b7425f9143a8d24a3b5538943c423895911ce5d673
diff --git a/net-misc/unison/files/unison-2.27.57-as-needed.patch b/net-misc/unison/files/unison-2.27.57-as-needed.patch
new file mode 100644
index 0000000..ff5be04
--- /dev/null
+++ b/net-misc/unison/files/unison-2.27.57-as-needed.patch
@@ -0,0 +1,11 @@
+--- unison-2.17.1/Makefile.OCaml
++++ unison-2.17.1/Makefile.OCaml
+@@ -330,7 +330,7 @@
+
+ $(NAME)$(EXEC_EXT): $(CAMLOBJS) $(COBJS)
+ @echo Linking $@
+- $(CAMLC) -verbose $(CAMLFLAGS) -o $@ $(CFLAGS) $(CAMLLIBS) $(CLIBS) $^
++ $(CAMLC) -verbose $(CAMLFLAGS) -o $@ $(CFLAGS) $(CAMLLIBS) $^ $(CLIBS)
+
+ # Unfortunately -output-obj does not put .o files into the output, only .cmx
+ # files, so we have to use $(LD) to take care of COBJS.
diff --git a/net-misc/unison/files/unison-2.40.61-makefile.patch b/net-misc/unison/files/unison-2.40.61-makefile.patch
new file mode 100644
index 0000000..67ad9ec
--- /dev/null
+++ b/net-misc/unison/files/unison-2.40.61-makefile.patch
@@ -0,0 +1,12 @@
+diff -Naur unison-2.40.61/Makefile unison-2.40.61_fix/Makefile
+--- unison-2.40.61/Makefile 2010-10-08 17:44:59.000000000 +0200
++++ unison-2.40.61_fix/Makefile 2011-02-07 22:54:33.000000000 +0100
+@@ -60,7 +60,7 @@
+ # NAME, VERSION, and MAJORVERSION, automatically generated
+ -include Makefile.ProjectInfo
+
+-Makefile.ProjectInfo: mkProjectInfo.ml $(wildcard ../.bzr/branch/last-revision)
++Makefile.ProjectInfo: mkProjectInfo $(wildcard ../.bzr/branch/last-revision)
+ ./mkProjectInfo > $@
+
+ mkProjectInfo: mkProjectInfo.ml
diff --git a/net-misc/unison/files/unison-mymap.patch b/net-misc/unison/files/unison-mymap.patch
new file mode 100644
index 0000000..030eb0f
--- /dev/null
+++ b/net-misc/unison/files/unison-mymap.patch
@@ -0,0 +1,13 @@
+Index: unison-2.32.52/update.mli
+===================================================================
+--- unison-2.32.52.orig/update.mli
++++ unison-2.32.52/update.mli
+@@ -1,7 +1,7 @@
+ (* Unison file synchronizer: src/update.mli *)
+ (* Copyright 1999-2009, Benjamin C. Pierce (see COPYING for details) *)
+
+-module NameMap : Map.S with type key = Name.t
++module NameMap : MyMap.S with type key = Name.t
+
+ type archive =
+ ArchiveDir of Props.t * archive NameMap.t
diff --git a/net-misc/unison/unison-2.40.16.ebuild b/net-misc/unison/unison-2.40.16.ebuild
new file mode 100644
index 0000000..4baf8f7
--- /dev/null
+++ b/net-misc/unison/unison-2.40.16.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.32.52.ebuild,v 1.4 2010/08/05 06:16:50 aballier Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt test"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )
+ test? ( || ( dev-util/ctags virtual/emacs ) )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_prepare() {
+ #epatch "${FILESDIR}/${PN}-2.27.57-as-needed.patch"
+ epatch "${FILESDIR}/${PN}-mymap.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable || die "error making unsion"
+}
+
+src_test() {
+ emake selftest || die "selftest failed"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT} || die
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html" || die
+ dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}
diff --git a/net-misc/unison/unison-2.40.61.ebuild b/net-misc/unison/unison-2.40.61.ebuild
new file mode 100644
index 0000000..6173ddb
--- /dev/null
+++ b/net-misc/unison/unison-2.40.61.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.32.52.ebuild,v 1.4 2010/08/05 06:16:50 aballier Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+IUSE="gtk doc static debug threads +ocamlopt test"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+# ocaml version so we are sure it has ocamlopt use flag
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.2 )
+ test? ( || ( dev-util/ctags virtual/emacs ) )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2
+ || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
+ !net-misc/unison:0
+ app-admin/eselect-unison"
+
+#PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+ doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.40.61-makefile.patch"
+ #epatch "${FILESDIR}/${PN}-2.27.57-as-needed.patch"
+ #epatch "${FILESDIR}/${PN}-mymap.patch"
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ use ocamlopt || myconf="$myconf NATIVE=false"
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" buildexecutable || die "error making unsion"
+}
+
+src_test() {
+ emake selftest || die "selftest failed"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ newbin unison unison-${SLOT} || die
+ dodoc BUGS.txt CONTRIB INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml "${DISTDIR}/${P}-manual.html" || die
+ dodoc "${DISTDIR}/${P}-manual.pdf" || die
+ fi
+ use ocamlopt || export STRIP_MASK="*/bin/*"
+}
+
+pkg_postinst() {
+ elog "Unison now uses SLOTs, so you can specify servercmd=/usr/bin/unison-${SLOT}"
+ elog "in your profile files to access exactly this version over ssh."
+ elog "Or you can use 'eselect unison' to set the version."
+}