summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaroslav Hron <jaroslav.hron@mff.cuni.cz>2011-11-28 19:06:24 +0100
committerJaroslav Hron <jaroslav.hron@mff.cuni.cz>2011-11-28 19:06:24 +0100
commit78710a57eaa407ef0870f15e65bc5096de2ca1f1 (patch)
tree927568b118b6a4add71e1508f98921862d5b43e5
parentadd gnome global menu (diff)
downloadjxh-78710a57eaa407ef0870f15e65bc5096de2ca1f1.tar.gz
jxh-78710a57eaa407ef0870f15e65bc5096de2ca1f1.tar.bz2
jxh-78710a57eaa407ef0870f15e65bc5096de2ca1f1.zip
update gedit-latex plugin dependenceies
-rw-r--r--gnome-extra/gedit-latex/Manifest1
-rw-r--r--gnome-extra/gedit-latex/gedit-latex-0.2-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gedit-latex/Manifest b/gnome-extra/gedit-latex/Manifest
index 3e25549..3a78804 100644
--- a/gnome-extra/gedit-latex/Manifest
+++ b/gnome-extra/gedit-latex/Manifest
@@ -1,2 +1,3 @@
DIST LaTeXPlugin-0.2.tar.gz 244202 RMD160 1ecd014c20a8fc2b990ea8c3f9b3322df87f3b82 SHA1 c1eabe1300a8dd1af0ed952ff7f2ec64e5dd24f9 SHA256 9062257a82d515a76cf4cb5f2c035d35640dcea17ad4db7be7f7d453916a418a
+EBUILD gedit-latex-0.2-r1.ebuild 1152 RMD160 090b1f1f6f0ede8b18b73ba714cbd0a54389f614 SHA1 2119837ed16ff215a19c058c0e325e5518f53fea SHA256 87c85f8cec4145af2a76842b027cd9bef26c8bfe1181f581d44af14b1b06e988
EBUILD gedit-latex-0.2.ebuild 1094 RMD160 86fe21963f32f23778229edfcb3fa48c077f66ba SHA1 6e68f445ca87d53c83bf46e09d2a2b8d92789b71 SHA256 4adbb5ee380fa735e1f4579b925e03590ac522056aa6f4d3e3ac83676a3cb902
diff --git a/gnome-extra/gedit-latex/gedit-latex-0.2-r1.ebuild b/gnome-extra/gedit-latex/gedit-latex-0.2-r1.ebuild
new file mode 100644
index 0000000..06ac486
--- /dev/null
+++ b/gnome-extra/gedit-latex/gedit-latex-0.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils python
+
+DESCRIPTION="LaTeX plugin for gedit"
+HOMEPAGE="http://live.gnome.org/Gedit/LaTeXPlugin"
+SRC_URI="mirror://sourceforge/${PN}/LaTeXPlugin-${PV/_rc/rc}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND=">=app-editors/gedit-2.15.2[python]
+ dev-python/gnome-vfs-python
+ dev-python/dbus-python
+ dev-python/pygtk
+ dev-python/pyenchant
+ dev-tex/rubber"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ mv GeditLaTeXPlugin ${PN}
+ mv GeditLaTeXPlugin.gedit-plugin ${PN}.gedit-plugin
+ sed -i -e "s/GeditLaTeXPlugin/${PN}/g" ${PN}.gedit-plugin ${PN}/src/base/resources.py
+ rm ${PN}/ChangeLog
+ rm ${PN}/INSTALL
+ rm ${PN}/COPYING
+ insinto /usr/$(get_libdir)/gedit-2/plugins
+ doins -r *
+ fperms 755 /usr/$(get_libdir)/gedit-2/plugins/${PN}/util/eps2png.pl
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/gedit-2/plugins/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/gedit-2/plugins/${PN}
+}