summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2013-07-26 12:05:21 -0400
committerJustin Riley <justin.t.riley@gmail.com>2013-07-26 12:05:21 -0400
commitad0072edf44e8c644bc7b2e282fde18805bbb1da (patch)
treed6fce03dd538d036e3173c339062f774befcba72 /dev-python/iptools
parentawesome: add 3.4.13 ebuild from bug 421025 (diff)
downloadjtriley-ad0072edf44e8c644bc7b2e282fde18805bbb1da.tar.gz
jtriley-ad0072edf44e8c644bc7b2e282fde18805bbb1da.tar.bz2
jtriley-ad0072edf44e8c644bc7b2e282fde18805bbb1da.zip
starcluster: add new 0.94 ebuild
* Added new package: iptools 0.6.1 * StarCluster now depends on optcomplete (in tree) and iptools (not in tree) * Updated live ebuild with changes from new 0.94 ebuild * Remove old and outdated 0.93.3 ebuild * Updated the starcluster Manifest
Diffstat (limited to 'dev-python/iptools')
-rw-r--r--dev-python/iptools/Manifest1
-rw-r--r--dev-python/iptools/iptools-0.6.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/iptools/Manifest b/dev-python/iptools/Manifest
new file mode 100644
index 0000000..c2ef322
--- /dev/null
+++ b/dev-python/iptools/Manifest
@@ -0,0 +1 @@
+DIST iptools-0.6.1.tar.gz 13928 SHA256 0f03875a5bed740ba4bf44decb6a78679cca914a1ee8a6cc468114485c4d98e3 SHA512 5a2b7fab028cc81699b791bf1669c3eb8311af1d9b17b2f3aa4bdd92dae3a9dc4ec38cf1de385bb592559b0ce560764debc152f11d98e6082e6c9fcdf643db3b WHIRLPOOL f69a5bbb926a59c6dc21eac2dd86ffc86402144d3dcca7d5a86bc5c96c44acaf7d3c59a233ce42ea84486dc6a843952161e37e81cad99c6133dd5add794f262e
diff --git a/dev-python/iptools/iptools-0.6.1.ebuild b/dev-python/iptools/iptools-0.6.1.ebuild
new file mode 100644
index 0000000..8183dd4
--- /dev/null
+++ b/dev-python/iptools/iptools-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.9.8.ebuild,v 1.1 2013/07/21 09:05:17 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils-r1
+
+DESCRIPTION="Python utilites for manipulating IPv4 and IPv6 addresses"
+HOMEPAGE="https://github.com/bd808/python-iptools http://pypi.python.org/pypi/iptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die -v tests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # iptools doesnt package its sphinx Makefile, config, templates, etc.
+ # for now install the single doc until the following PR gets merged and
+ # released: https://github.com/bd808/python-iptools/pull/10
+ use doc && dodoc docs/index.rst
+}