summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/efitools')
-rw-r--r--app-crypt/efitools/Manifest1
-rw-r--r--app-crypt/efitools/efitools-1.5.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/efitools/Manifest b/app-crypt/efitools/Manifest
new file mode 100644
index 0000000..e9ea196
--- /dev/null
+++ b/app-crypt/efitools/Manifest
@@ -0,0 +1 @@
+EBUILD efitools-1.5.3.ebuild 860 SHA256 56e524f149ad24d823d9419ce0bd8e97d1031076b24c18f916f6eb1acd908ca9 SHA512 0eb41d301588d4c85f086fd3569dc7c22b4ddded8ef3ff68588d2659c9d99e9254756658138a90f80387924f26b3f7107c7086f46a6361068a7472b91e4f829f WHIRLPOOL 621182eb485375c03d6c885245b05759fc8ec716f516db27c9e5cd70314de7db776afd05c42ef5eceb2e97834b137665d948e97b43f831c8cf4ec8544bf0f300
diff --git a/app-crypt/efitools/efitools-1.5.3.ebuild b/app-crypt/efitools/efitools-1.5.3.ebuild
new file mode 100644
index 0000000..45819d9
--- /dev/null
+++ b/app-crypt/efitools/efitools-1.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/efitools/efitools-1.4.2-r1.ebuild,v 1.3 2015/01/30 09:21:05 pinkbyte Exp $
+
+EAPI="4"
+inherit git-r3
+
+DESCRIPTION="Tools for manipulating UEFI secure boot platforms"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jejb/efitools.git"
+SRC_URI=""
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/jejb/efitools.git"
+EGIT_COMMIT="v1.5.2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ >=sys-boot/gnu-efi-3.0u
+ app-crypt/sbsigntool
+ virtual/pkgconfig
+ dev-perl/File-Slurp"
+
+src_compile() {
+ if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+ emake -j1 || die "emake failed"
+ fi
+}