summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-05-16 14:34:38 +0200
committerJens Pranaitis <jens@chaox.net>2010-05-16 14:34:38 +0200
commitf67a741fc8bf0201aa505c3c841d11b7498bea8a (patch)
tree698927e7477178a09341f59c36e9eeef8e1902e7
parentlugaru: Fix hg checkout (diff)
downloadjensp-f67a741fc8bf0201aa505c3c841d11b7498bea8a.tar.gz
jensp-f67a741fc8bf0201aa505c3c841d11b7498bea8a.tar.bz2
jensp-f67a741fc8bf0201aa505c3c841d11b7498bea8a.zip
added oalwrapper
-rw-r--r--media-libs/oalwrapper/Manifest2
-rw-r--r--media-libs/oalwrapper/oalwrapper-9999.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/oalwrapper/Manifest b/media-libs/oalwrapper/Manifest
new file mode 100644
index 0000000..3e07b17
--- /dev/null
+++ b/media-libs/oalwrapper/Manifest
@@ -0,0 +1,2 @@
+DIST HPL1Engine.tar.bz2 6803817 RMD160 c669d6657fa78a885688ea10f3c273244c91f576 SHA1 ec22afdd9ad4815a8b7794af69a10dfa0987f59a SHA256 aebfedc468c49e053897398f37e943eb3ea8874dfcd04b0b35dda03e3061929c
+EBUILD oalwrapper-9999.ebuild 683 RMD160 f50bffb330cf54b40bbf7b1b37e7a6c6e74745cc SHA1 c5948068b5826bae5219a9009b41d3fff61257e8 SHA256 eacb0db55f7c0986874fb4f10cc626914d2d434555fd4ae2d16facc93c0ebd1d
diff --git a/media-libs/oalwrapper/oalwrapper-9999.ebuild b/media-libs/oalwrapper/oalwrapper-9999.ebuild
new file mode 100644
index 0000000..78d614a
--- /dev/null
+++ b/media-libs/oalwrapper/oalwrapper-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils git
+
+CMAKE_IN_SOURCE_BUILD=1
+
+DESCRIPTION="wrapper for OpenAL"
+HOMEPAGE="http://github.com/FrictionalGames/OALWrapper"
+SRC_URI="http://chaox.net/~jens/HPL1Engine.tar.bz2"
+EGIT_REPO_URI="git://github.com/jensp/OALWrapper.git"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="media-libs/freealut
+ >=media-libs/openal-1.12.854
+ games-engine/hpl1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack "${A}" || die
+ git_src_unpack
+}
+
+src_install() {
+ insinto /usr/include
+ doins -r include/OALWrapper || die
+ dolib.a libOALWrapper.a || die
+}