summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-07-14 20:47:38 +0200
committerJens Pranaitis <jens@chaox.net>2010-07-14 20:47:38 +0200
commit160a2fca6c9259e10b2eea133c307920860102be (patch)
treec031fdffac029cfe72ffb966fcc0a6b5213da273
parentadded frogatto (proto ebuild, wip) (diff)
downloadjensp-160a2fca6c9259e10b2eea133c307920860102be.tar.gz
jensp-160a2fca6c9259e10b2eea133c307920860102be.tar.bz2
jensp-160a2fca6c9259e10b2eea133c307920860102be.zip
added pidgin with icq fix
-rw-r--r--net-im/pidgin/Manifest3
-rw-r--r--net-im/pidgin/files/pidgin-2.7.1-icq-fix.patch19
-rw-r--r--net-im/pidgin/pidgin-2.7.1-r2.ebuild211
3 files changed, 233 insertions, 0 deletions
diff --git a/net-im/pidgin/Manifest b/net-im/pidgin/Manifest
new file mode 100644
index 0000000..96c0dda
--- /dev/null
+++ b/net-im/pidgin/Manifest
@@ -0,0 +1,3 @@
+AUX pidgin-2.7.1-icq-fix.patch 710 RMD160 3c7db8b87dfb53b21c449378d3ad68d9cd98dad0 SHA1 c0c033db8966a76287c4f45a2d5bd681b3d12a16 SHA256 9f5de2d1441f8369f3f13733dc4ffe14e1be9395507b79703b1c849c02602f93
+DIST pidgin-2.7.1.tar.bz2 9647234 RMD160 5e5deec529b1c8d75cd3f925b3f5e4f5310e42e5 SHA1 b746720cc3e65b3d6da6eab0729f26673f997849 SHA256 f412a5a7389ad553229743b49399f968278095c8258dc0f89f766a6cd0ba95d1
+EBUILD pidgin-2.7.1-r2.ebuild 6299 RMD160 0f8066a81188f9e238662e6bd29468667851b6f8 SHA1 88566ea8abe788f7754118362d3a76a5c922750b SHA256 91141ebc146cb99207c15dc494c7ac73c1c6112eb2b0cfb3164551b2fc69708d
diff --git a/net-im/pidgin/files/pidgin-2.7.1-icq-fix.patch b/net-im/pidgin/files/pidgin-2.7.1-icq-fix.patch
new file mode 100644
index 0000000..8bb87ef
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.7.1-icq-fix.patch
@@ -0,0 +1,19 @@
+#
+#
+# patch "libpurple/protocols/oscar/oscar.c"
+# from [b448ff8a14ab7db9b3ad6ce2c8f17cac8159f702]
+# to [6b8b45623896204448ac4b212a0c631655822ad1]
+#
+============================================================
+--- libpurple/protocols/oscar/oscar.c b448ff8a14ab7db9b3ad6ce2c8f17cac8159f702
++++ libpurple/protocols/oscar/oscar.c 6b8b45623896204448ac4b212a0c631655822ad1
+@@ -4651,7 +4651,8 @@ oscar_send_im(PurpleConnection *gc, cons
+ tmp2 = purple_markup_strip_html(tmp1);
+ is_html = FALSE;
+ } else {
+- tmp2 = g_strdup(tmp1);
++ /* ICQ 6 wants its HTML wrapped in these tags. Oblige it. */
++ tmp2 = g_strdup_printf("<HTML><BODY>%s</BODY></HTML>", tmp1);
+ is_html = TRUE;
+ }
+ g_free(tmp1);
diff --git a/net-im/pidgin/pidgin-2.7.1-r2.ebuild b/net-im/pidgin/pidgin-2.7.1-r2.ebuild
new file mode 100644
index 0000000..0d7d408
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.7.1-r2.ebuild
@@ -0,0 +1,211 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.7.1-r1.ebuild,v 1.7 2010/07/11 10:29:30 hwoarang Exp $
+
+EAPI=2
+
+GENTOO_DEPEND_ON_PERL=no
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2 python
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~ppc ppc64 sparc x86"
+IUSE="dbus debug doc eds gadu gnutls +gstreamer +gtk idn krb4 meanwhile"
+IUSE+=" networkmanager nls perl silc tcl tk spell qq sasl +startup-notification"
+IUSE+=" ncurses groupwise prediction python +xscreensaver zephyr zeroconf" # mono"
+
+# dbus requires python to generate C code for dbus bindings (thus DEPEND only).
+# finch uses libgnt that links with libpython - {R,}DEPEND. But still there is
+# no way to build dbus and avoid libgnt linkage with python. If you want this
+# send patch upstream.
+RDEPEND="
+ >=dev-libs/glib-2.12
+ >=dev-libs/libxml2-2.6.18
+ ncurses? ( sys-libs/ncurses[unicode]
+ dbus? ( <dev-lang/python-3 )
+ python? ( <dev-lang/python-3 ) )
+ gtk? (
+ >=x11-libs/gtk+-2.10:2
+ x11-libs/libSM
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ startup-notification? ( >=x11-libs/startup-notification-0.5 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ eds? ( gnome-extra/evolution-data-server )
+ prediction? ( >=dev-db/sqlite-3.3:3 ) )
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ >=net-libs/farsight2-0.0.14
+ media-plugins/gst-plugins-meta
+ media-plugins/gst-plugins-gconf )
+ zeroconf? ( net-dns/avahi )
+ dbus? ( >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.90 )
+ perl? ( >=dev-lang/perl-5.8.2-r1[-build] )
+ gadu? ( >=net-libs/libgadu-1.9.0[-ssl] )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-1.0.1 )
+ zephyr? ( >=app-crypt/mit-krb5-1.3.6-r1[krb4?] )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ networkmanager? ( net-misc/networkmanager )
+ idn? ( net-dns/libidn )"
+ # Mono support crashes pidgin
+ #mono? ( dev-lang/mono )"
+
+DEPEND="$RDEPEND
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ gtk? ( x11-proto/scrnsaverproto )
+ dbus? ( <dev-lang/python-3 )
+ doc? ( app-doc/doxygen )
+ nls? ( >=dev-util/intltool-0.41.1
+ sys-devel/gettext )"
+
+DOCS="AUTHORS HACKING NEWS README ChangeLog"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/msn-pecan
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgin-latex
+# x11-plugins/pidgintex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+# x11-plugins/pidgin-knotify
+# Plugins in Sunrise:
+# x11-plugins/pidgimpd
+# x11-plugins/pidgin-birthday
+# x11-plugins/pidgin-botsentry
+# x11-plugins/pidgin-convreverse
+# x11-plugins/pidgin-extended-blist-sort
+# x11-plugins/pidgin-lastfm
+# x11-plugins/pidgin-mbpurple
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ einfo
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ einfo
+ fi
+ if ! use xscreensaver; then
+ elog "Note: xscreensaver USE flag is disabled. Thus pidgin will be unable"
+ elog "to monitor idle/active status based on mouse/keyboard events"
+ fi
+ if use dbus && ! use python; then
+ elog "It's impossible to disable linkage with python in case dbus is enabled."
+ fi
+ if use dbus || { use ncurses && use python; }; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-icq-fix.patch || die
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ use silc && DYNAMIC_PRPLS+=",silc"
+ use qq && DYNAMIC_PRPLS+=",qq"
+ use meanwhile && DYNAMIC_PRPLS+=",sametime"
+ use zeroconf && DYNAMIC_PRPLS+=",bonjour"
+ use groupwise && DYNAMIC_PRPLS+=",novell"
+ use zephyr && DYNAMIC_PRPLS+=",zephyr"
+
+ if use gnutls; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf+=" --enable-nss=no --enable-gnutls=yes"
+ myconf+=" --with-gnutls-includes=/usr/include/gnutls"
+ myconf+=" --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf+=" --enable-gnutls=no --enable-nss=yes"
+ fi
+
+ if use dbus || { use ncurses && use python; }; then
+ myconf+=" --with-python=$(PYTHON)"
+ else
+ myconf+=" --without-python"
+ fi
+
+ econf \
+ $(use_enable ncurses consoleui) \
+ $(use_enable nls) \
+ $(use_enable gtk gtkui) \
+ $(use_enable gtk sm) \
+ $(use gtk && use_enable startup-notification) \
+ $(use gtk && use_enable xscreensaver screensaver) \
+ $(use gtk && use_enable prediction cap) \
+ $(use gtk && use_enable eds gevolution) \
+ $(use gtk && use_enable spell gtkspell) \
+ $(use_enable perl) \
+ $(use_enable tk) \
+ $(use_enable tcl) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable gstreamer) \
+ $(use_enable gstreamer farsight) \
+ $(use_enable gstreamer vv) \
+ $(use_enable sasl cyrus-sasl ) \
+ $(use_enable doc doxygen) \
+ $(use_enable networkmanager nm) \
+ $(use zephyr && use_with krb4) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable idn) \
+ "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ --disable-mono \
+ --x-includes=/usr/include/X11 \
+ ${myconf}
+ #$(use_enable mono) \
+}
+
+src_install() {
+ gnome2_src_install
+ if use gtk; then
+ # Fix tray pathes for kde-3.5, e16 (x11-wm/enlightenment) and other
+ # implementations that are not complient with new hicolor theme yet, #323355
+ local pixmapdir
+ for d in 16 22 32 48; do
+ pixmapdir=${D}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions
+ mkdir "${pixmapdir}" || die
+ pushd "${pixmapdir}" >/dev/null || die
+ for f in ../status/*; do
+ ln -s ${f} || die
+ done
+ popd >/dev/null
+ done
+ fi
+ use perl && fixlocalpod
+}