summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-07-04 17:15:18 +0200
committerJens Pranaitis <jens@chaox.net>2010-07-04 17:15:18 +0200
commit06d4422e414a7eecaeebf73e31c44bab78e08371 (patch)
treef7e0b191439272921858e6aa0dd9179d88be2bfa
parentadded glew 1.5.4, needed by lightspark-9999 (diff)
downloadjensp-06d4422e414a7eecaeebf73e31c44bab78e08371.tar.gz
jensp-06d4422e414a7eecaeebf73e31c44bab78e08371.tar.bz2
jensp-06d4422e414a7eecaeebf73e31c44bab78e08371.zip
added lightspark-9999
-rw-r--r--www-plugins/lightspark/Manifest2
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch15
-rw-r--r--www-plugins/lightspark/lightspark-9999.ebuild62
3 files changed, 79 insertions, 0 deletions
diff --git a/www-plugins/lightspark/Manifest b/www-plugins/lightspark/Manifest
new file mode 100644
index 0000000..44fcf4f
--- /dev/null
+++ b/www-plugins/lightspark/Manifest
@@ -0,0 +1,2 @@
+AUX lightspark-0.4.1-debug-defines.patch 389 RMD160 0e93e2c73aa44a1f65346e384d67cbc3352d3fbf SHA1 e336c195226c1f3b35ca7924576edec1de57d720 SHA256 e78cf93021e490dfd276f1b2f4a81b4d10c5f7b12ff5f8d26d06f0d2ccff5a24
+EBUILD lightspark-9999.ebuild 1372 RMD160 3a13c13c7a964b303f86b926c8fcf469116bca72 SHA1 469756b1a2027781f541633ce87054c05a86e504 SHA256 4570b5650c1f75bd40d02a281f5d5b5161dd18e44637af5de2576dba310acfd0
diff --git a/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch b/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch
new file mode 100644
index 0000000..f272dad
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch
@@ -0,0 +1,15 @@
+diff --git a/swftypes.h b/swftypes.h
+index 31e1a70..0c166cb 100644
+--- a/swftypes.h
++++ b/swftypes.h
+@@ -498,9 +498,9 @@ private:
+ public:
+ #ifndef NDEBUG
+ //Stuff only used in debugging
+- bool initialized;
+ int getRefCount(){ return ref_count; }
+ #endif
++ bool initialized;
+ bool implEnable;
+ void setPrototype(Class_base* c);
+ Class_base* getPrototype() const { return prototype; }
diff --git a/www-plugins/lightspark/lightspark-9999.ebuild b/www-plugins/lightspark/lightspark-9999.ebuild
new file mode 100644
index 0000000..db686fe
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils nsplugins multilib git
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="https://launchpad.net/lightspark/"
+EGIT_REPO_URI="git://github.com/alexp-sssup/lightspark.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+nsplugin debug"
+
+RDEPEND="dev-libs/libpcre
+ media-fonts/liberation-fonts
+ media-video/ffmpeg
+ media-libs/ftgl
+ media-libs/glew
+ media-libs/libsdl
+ net-misc/curl
+ >=sys-devel/llvm-2.7
+ virtual/opengl
+ nsplugin? (
+ dev-libs/nspr
+ net-libs/xulrunner
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Fix gcc complaint about undefined debug variable
+ if ! use debug; then
+ epatch "${FILESDIR}"/${PN}-0.4.1-debug-defines.patch
+ fi
+
+ # Adjust plugin permissions
+ sed -i "s|FILES|PROGRAMS|" plugin-dir/CMakeLists.txt || die
+
+ # Adjust font paths
+ sed -i "s|truetype/ttf-liberation|liberation-fonts|" swf.cpp || die
+}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ -DPLUGIN_DIRECTORY=/usr/$(get_libdir)/${PN}/plugins"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+}