aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.17.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.17.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.17.0.ebuild b/dev-python/websocket-client/websocket-client-0.17.0.ebuild
new file mode 100644
index 0000000..e780fe8
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.17.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WebSocket client for python that provides the low level APIs for WebSocket"
+HOMEPAGE="https://github.com/liris/websocket-client https://pypi.python.org/pypi/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed -e 's:"tests", ::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" tests/test_websocket.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}