aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/catbox/catbox-1.6.2.ebuild')
-rw-r--r--dev-python/catbox/catbox-1.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/catbox/catbox-1.6.2.ebuild b/dev-python/catbox/catbox-1.6.2.ebuild
new file mode 100644
index 0000000..0980071
--- /dev/null
+++ b/dev-python/catbox/catbox-1.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast sandbox implementation for Python"
+HOMEPAGE=" https://github.com/Pardus-Linux/catbox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testify[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testify tests || die "Tests failed under ${EPYTHON}"
+}
+
+# Circular dep of testify to run the testsuite
+pkg_post_inst() {
+ elog "To run the testsuite, emerge testify spearately,"
+ elog, "then re-run using FEATURES=test"
+}