summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2018-12-01 21:33:32 +0100
committerhaarp <main.haarp@gmail.com>2018-12-01 22:07:50 +0100
commit6e86fc64e2545b448fe731ef0f4b01efc3fa73fd (patch)
treeedfde4169acca13cf2ea3bb77a0a78b0ee0042a5 /media-gfx
parentAlacritty is in Gentoo tree now! (diff)
downloadhaarp-6e86fc64e2545b448fe731ef0f4b01efc3fa73fd.tar.gz
haarp-6e86fc64e2545b448fe731ef0f4b01efc3fa73fd.tar.bz2
haarp-6e86fc64e2545b448fe731ef0f4b01efc3fa73fd.zip
Add Slic3r Prusa Edition
based on work by Piotr Stachura, https://bugs.gentoo.org/652100 note that newer versions don't work yet with this ebuild. Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/slic3r-prusa3d/Manifest2
-rw-r--r--media-gfx/slic3r-prusa3d/metadata.xml7
-rw-r--r--media-gfx/slic3r-prusa3d/slic3r-prusa3d-1.40.0.ebuild120
3 files changed, 129 insertions, 0 deletions
diff --git a/media-gfx/slic3r-prusa3d/Manifest b/media-gfx/slic3r-prusa3d/Manifest
new file mode 100644
index 0000000..7139191
--- /dev/null
+++ b/media-gfx/slic3r-prusa3d/Manifest
@@ -0,0 +1,2 @@
+EBUILD slic3r-prusa3d-1.40.0.ebuild 2990 BLAKE2B 675664d6fc0cdf17ff3f245a0e41babe4cc1e34807eb85c003170461390af17243d4f3a122fc0eb8a193f90ad5f395d73482d5fb0cdfafd8750a103a702e656c SHA512 7b5ad367f21c7e1e5005e684ec4aab7438b96134adb9ce5a11f27f29208e30c4b9e8cd508c50493b7f4ff5924fc87a5c31c333e94948ae7774bce19fee2f8b8b
+MISC metadata.xml 203 BLAKE2B c6e21b67977c25397c014c8a709a0568bef0d455dbad7aa9787c63895c9dac8e1405522bc1dc82745b18d37f48d01a822ca29880ea374c895446dfba5c33d9cc SHA512 05b7902daead1819658dd3c1b9539056a410ed454703125399504ef2816dced3dfb606894ada0ca325da3e149f845078fefa21af4fb24e9d224d93813d66e68e
diff --git a/media-gfx/slic3r-prusa3d/metadata.xml b/media-gfx/slic3r-prusa3d/metadata.xml
new file mode 100644
index 0000000..b119258
--- /dev/null
+++ b/media-gfx/slic3r-prusa3d/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="gui">Enable GUI</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/slic3r-prusa3d/slic3r-prusa3d-1.40.0.ebuild b/media-gfx/slic3r-prusa3d/slic3r-prusa3d-1.40.0.ebuild
new file mode 100644
index 0000000..9061b94
--- /dev/null
+++ b/media-gfx/slic3r-prusa3d/slic3r-prusa3d-1.40.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# https://bugs.gentoo.org/652100
+
+EAPI=6
+
+inherit eutils git-r3 perl-module cmake-utils
+
+DESCRIPTION="Improved G-code generator for Prusa 3D printers"
+HOMEPAGE="https://www.prusa3d.com/slic3r-prusa-edition/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/prusa3d/Slic3r.git"
+EGIT_COMMIT="303ed0e"
+
+LICENSE="AGPL-3 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui test"
+
+# check Build.PL for dependencies
+RDEPEND="!=dev-lang/perl-5.16*
+ !media-gfx/slic3r
+ dev-cpp/tbb
+ >=dev-libs/boost-1.55[threads]
+ dev-perl/Class-XSAccessor
+ dev-perl/Devel-CheckLib
+ dev-perl/Devel-Size
+ >=dev-perl/Encode-Locale-1.50.0
+ dev-perl/IO-stringy
+ dev-perl/local-lib
+ >=dev-perl/Math-PlanePath-53.0.0
+ >=dev-perl/Moo-1.3.1
+ dev-perl/XML-SAX-ExpatXS
+ virtual/perl-Carp
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-parent
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+ virtual/perl-Thread-Semaphore
+ >=virtual/perl-threads-1.960.0
+ virtual/perl-Time-HiRes
+ virtual/perl-Unicode-Normalize
+ virtual/perl-XSLoader
+ gui? ( dev-perl/Class-Accessor
+ dev-perl/Growl-GNTP
+ dev-perl/libwww-perl
+ dev-perl/Module-Pluggable
+ dev-perl/Net-Bonjour
+ dev-perl/Net-DBus
+ dev-perl/OpenGL
+ >=dev-perl/Wx-0.991.800
+ dev-perl/Wx-GLCanvas
+ >=media-libs/freeglut-3
+ virtual/perl-Math-Complex
+ >=virtual/perl-Socket-2.16.0
+ x11-libs/libXmu
+ )"
+DEPEND="${RDEPEND}
+ dev-perl/Devel-CheckLib
+ >=dev-perl/ExtUtils-CppGuess-0.70.0
+ >=dev-perl/ExtUtils-Typemaps-Default-1.50.0
+ >=dev-perl/ExtUtils-XSpp-0.170.0
+ >=dev-perl/Module-Build-0.380.0
+ >=dev-perl/Module-Build-WithXSpp-0.140.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.800.0
+ >=virtual/perl-ExtUtils-ParseXS-3.220.0
+ test? ( virtual/perl-Test-Harness
+ virtual/perl-Test-Simple )"
+
+S="${WORKDIR}/slic3r-prusa3d-${PV}"
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ pushd "${S}" || die
+ sed -i lib/Slic3r.pm -e "s@FindBin::Bin@FindBin::RealBin@g" || die
+ eapply_user
+ popd || die
+}
+
+src_configure() {
+ SLIC3R_NO_AUTO=1 perl-module_src_configure
+ cmake-utils_src_configure
+}
+
+src_test() {
+ perl-module_src_test
+ pushd .. || die
+ prove -Ixs/blib/arch -Ixs/blib/lib/ t/ || die "Tests failed"
+ popd || die
+}
+
+src_install() {
+ perl-module_src_install
+ insinto "${VENDOR_LIB}"
+ doins -r lib/Slic3r.pm lib/Slic3r
+ insinto "${VENDOR_LIB}"/Slic3r
+ doins -r resources
+
+ exeinto "${VENDOR_LIB}"/Slic3r
+ doexe slic3r.pl
+
+ dosym "${VENDOR_LIB}"/Slic3r/slic3r.pl /usr/bin/slic3r.pl
+ dosym /usr/lib64/perl5/vendor_perl/5.24.3/Slic3r/resources/icons/Slic3r_128px.png \
+ /usr/share/pixmaps/slic3r.png
+
+ make_desktop_entry slic3r.pl \
+ "Slic3r Prusa Edition" \
+ "slic3r.png" \
+ "Graphics;3DGraphics;Engineering;Development"
+ # xfce4-panel skips files with multiple dots
+ mv "${D}/usr/share/applications/slic3r.pl-slic3r-prusa3d.desktop" \
+ "${D}/usr/share/applications/slic3r-prusa3d.desktop"
+
+ cmake-utils_src_install
+}