summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2019-08-17 20:19:47 +0200
committerhaarp <main.haarp@gmail.com>2019-08-17 20:20:29 +0200
commita7597b2d6d7a0a6531c2bf1cda57f42ddd7aa78c (patch)
treef99f3832a897c208170a9d47b1c7d04d6722a8f5 /games-fps
parentGZDoom 4.2.0 and 9999 based on Gentoo repo's ebuild (diff)
downloadhaarp-a7597b2d6d7a0a6531c2bf1cda57f42ddd7aa78c.tar.gz
haarp-a7597b2d6d7a0a6531c2bf1cda57f42ddd7aa78c.tar.bz2
haarp-a7597b2d6d7a0a6531c2bf1cda57f42ddd7aa78c.zip
Make Zandronum brightmaps.pk3 compatible with parallel install of gzdoom
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/zandronum/Manifest2
-rw-r--r--games-fps/zandronum/zandronum-3.0-r1.ebuild (renamed from games-fps/zandronum/zandronum-3.0.ebuild)40
2 files changed, 25 insertions, 17 deletions
diff --git a/games-fps/zandronum/Manifest b/games-fps/zandronum/Manifest
index ce6bf13..0f36a34 100644
--- a/games-fps/zandronum/Manifest
+++ b/games-fps/zandronum/Manifest
@@ -1,3 +1,3 @@
DIST zandronum-3.0.tar.bz2 5495206 BLAKE2B 2d9690285a3eb6a82432e6c1dec122f3cb395780478286e9d8ffc3096b71b9bb6fbbb3f19d712f7cc13de496d46ea8fc6cd75dcd2c80101f56f201242ec55394 SHA512 55f3ce2dacc9ae6127de0feb92604668f394061a94ee473082dab8ca845410f1568a00e5543d4f4d00b028e33c866ea5f129fd226b14d419aa327e14a0e9ef56
-EBUILD zandronum-3.0.ebuild 2967 BLAKE2B 7085a3e48b1b8c3a1774a6ccc471ec8d46caeecbda98c105218b079cce979cf3f348a4d2d1956e2644d6457cede5245288ee70ecfa9d51a2847ee346adcb1db2 SHA512 0c5eee0038c7c9bde4bcb4c36b15826e68201d58baea4d810c9cb66dd877205b0d9cd58d52b950bcbb8bb82972d237b3879588c1c1d1f53bc18ccea2a7e4af5c
+EBUILD zandronum-3.0-r1.ebuild 3504 BLAKE2B 5be60639bee48a39d8372d602c8358b605a543aacadea63d1edcd14c19d2647f13ea6752b402b94b0b4038d1d32955cdb7a2c94a3a5e991d74ef09247f52bae9 SHA512 3e475fbcb690431d0f512b0517913007dcd7bd11d653ec5c6ea6535dfe188985fc7a6bd273bd4bbc75d1f9145e4906aa8c4c212d135398c77d8d5fbc5369f830
MISC metadata.xml 315 BLAKE2B d774a34d761497e43beb2078fc93e107b12d591b05e2439e2caaa7d1b11831151b9be6a7acf745d38ab726a887a8a4793dce11de9ec6b435e5df1db4227e748d SHA512 0e1da3132a25e09577a6861dea211f8ae941b6f4d1adbdc4b9a16c9b5bb1f9c8c96f6272a304d1b0b0a80c85965e72511203296e4f4622d1c0ba1d687f9854d2
diff --git a/games-fps/zandronum/zandronum-3.0.ebuild b/games-fps/zandronum/zandronum-3.0-r1.ebuild
index 656690f..6a38767 100644
--- a/games-fps/zandronum/zandronum-3.0.ebuild
+++ b/games-fps/zandronum/zandronum-3.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils cmake-utils
+inherit cmake-utils desktop
OWNER="Torr_Samaho"
MY_COMMIT="dd3c3b57023f"
@@ -11,8 +11,7 @@ MY_COMMIT_UTC_TIMESTAMP="1504266050"
DESCRIPTION="OpenGL ZDoom port with Client/Server multiplayer"
HOMEPAGE="https://zandronum.com/"
-SRC_URI="https://bitbucket.org/${OWNER}/${PN}/get/${MY_COMMIT}.tar.bz2 -> ${P}.tar.bz2
-"
+SRC_URI="https://bitbucket.org/${OWNER}/${PN}/get/${MY_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
LICENSE="Sleepycat"
SLOT="0"
@@ -26,13 +25,14 @@ REQUIRED_USE="|| ( dedicated opengl )
RDEPEND="gtk? ( x11-libs/gtk+:2 )
timidity? ( media-sound/timidity++ )
opengl? ( media-libs/fmod:1
- media-libs/libsdl
+ media-libs/libsdl[opengl]
virtual/glu
virtual/jpeg:62
virtual/opengl
)
dev-db/sqlite
- dev-libs/openssl:0"
+ dev-libs/openssl:0
+ media-sound/fluidsynth"
DEPEND="${RDEPEND}
cpu_flags_x86_mmx? ( || ( dev-lang/nasm dev-lang/yasm ) )"
@@ -53,20 +53,20 @@ src_prepare() {
sed -i -e "/add_subdirectory( sqlite )/d" CMakeLists.txt
# Use default data path
- sed -i -e "s:/usr/local/share/:/usr/share/doom-data/:" src/sdl/i_system.h
+ sed -i -e "s:/usr/local/share/:/usr/share/doom/:" src/sdl/i_system.h
# Fix building with gcc-5
sed -i -e 's/ restrict/ _restrict/g' dumb/include/dumb.h dumb/src/it/*.c
- eapply_user
+ cmake-utils_src_prepare
}
src_configure() {
mycmakeargs=(
- -DNO_ASM="$(usex cpu_flags_x86_mmx OFF ON)"
- -DNO_GTK="$(usex gtk OFF ON)"
-DFMOD_INCLUDE_DIR=/opt/fmodex/api/inc/
-DFMOD_LIBRARY=/opt/fmodex/api/lib/libfmodex.so
+ -DNO_ASM="$(usex cpu_flags_x86_mmx OFF ON)"
+ -DNO_GTK="$(usex gtk OFF ON)"
)
# Can't build both client and server at once... so separate them
@@ -96,7 +96,7 @@ src_install() {
dodoc docs/{commands,zandronum*}.txt docs/console.{css,html}
cd "${BUILD_DIR}"
- insinto "/usr/share/doom-data"
+ insinto "/usr/share/doom"
doins *.pk3
if use opengl; then
@@ -107,14 +107,22 @@ src_install() {
if use dedicated; then
dobin "${WORKDIR}/${P}_server/${PN}-server"
fi
-}
+ # don't install this now
+ rm "${D}/usr/share/doom/brightmaps.pk3"
+}
pkg_postinst() {
- elog "Copy or link wad files into /usr/share/doom-data/"
- elog "ATTENTION: The path has changed! It used to be /usr/share/games/doom-data/"
+ # install here to avoid collisions with games-fps/zandronum
+ # hacky, i know. should've listened to juippis :) please don't hit me.
+ cp -n "${BUILD_DIR}/brightmaps.pk3" "${EPREFIX}/usr/share/doom/" || die
+
+ ewarn "For parity with the gzdoom ebuild, the data path has been changed yet again!"
+ ewarn "It is ${EPREFIX}/usr/share/doom - copy/link wad files there or in \$HOME/.config/zandronum"
+ ewarn "If after an upgrade the game complains about not finding zandronum.pk3,"
+ ewarn "edit the [*Search.Directories] sections in \$HOME/.config/zandronum/zandronum.ini."
+
if use opengl; then
elog
- elog "To play, install games-util/doomseeker or simply run:"
- elog " zandronum"
+ elog "To play online, install games-util/doomseeker"
fi
}