summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen-overlay@occam.eroen.eu>2016-10-12 18:46:02 +0200
committereroen <eroen-overlay@occam.eroen.eu>2016-10-12 18:46:02 +0200
commitde1ba250d1da83043974808ca14c92670c3f0a8f (patch)
treeca4bb30ff1815de526c8a0af55a414329d5157a4 /x11-terms
parentsteam.eclass - cleanup (diff)
downloaderoen-de1ba250d1da83043974808ca14c92670c3f0a8f.tar.gz
eroen-de1ba250d1da83043974808ca14c92670c3f0a8f.tar.bz2
eroen-de1ba250d1da83043974808ca14c92670c3f0a8f.zip
termite,vte - bump, fixes build with gcc 6
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/termite/termite-12.ebuild66
-rw-r--r--x11-terms/termite/termite-9999.ebuild33
2 files changed, 84 insertions, 15 deletions
diff --git a/x11-terms/termite/termite-12.ebuild b/x11-terms/termite/termite-12.ebuild
new file mode 100644
index 0000000..4df0fd2
--- /dev/null
+++ b/x11-terms/termite/termite-12.ebuild
@@ -0,0 +1,66 @@
+# By eroen, 2013-2016
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+
+EAPI=6
+
+inherit eutils toolchain-funcs versionator
+if [[ 9999 == $PV ]]; then
+ inherit git-r3
+else
+ # Submodules :-(
+ #SRC_URI="https://github.com/thestinger/termite/archive/v$PV.tar.gz -> $P.tar.gz"
+ inherit git-r3
+ EGIT_COMMIT=v$PV
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A keyboard-centric VTE-based terminal"
+HOMEPAGE="https://github.com/thestinger/termite"
+EGIT_REPO_URI="git://github.com/thestinger/termite.git
+ http://github.com/thestinger/termite.git
+ https://github.com/thestinger/termite.git"
+
+LICENSE="LGPL-2+ MIT"
+SLOT="0"
+IUSE=""
+
+LIBDEPEND=">=x11-libs/gtk+-3.0
+ >=x11-libs/vte-0.43.2:2.91[termite-patch(-)]
+ "
+DEPEND="${LIBDEPEND}"
+RDEPEND="${LIBDEPEND}"
+
+pkg_pretend() {
+ if ! version_is_at_least 4.7 $(gcc-version); then
+ eerror "${PN} passes -std=c++11 to \${CXX} and requires a version"
+ eerror "of gcc newer than 4.7.0"
+ fi
+}
+
+pkg_setup() {
+ # Makefile prepends -O3
+ CXXFLAGS="-O0 ${CXXFLAGS}"
+}
+
+src_prepare() {
+ default
+ sed -e "s/^VERSION = .*$/VERSION = v${PV}/" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README* config
+}
+
+pkg_postinst() {
+ elog
+ elog "Termite looks for a config file ~/.config/termite/config"
+ elog "An example config can be found in ${EROOT}usr/share/doc/${PF}/"
+}
diff --git a/x11-terms/termite/termite-9999.ebuild b/x11-terms/termite/termite-9999.ebuild
index ec921b0..60c8783 100644
--- a/x11-terms/termite/termite-9999.ebuild
+++ b/x11-terms/termite/termite-9999.ebuild
@@ -1,30 +1,33 @@
-# By eroen, 2013-2015
-# Distributed under the terms of the ISC licence
-# $Header: $
-
-EAPI=5
-
-inherit eutils toolchain-funcs versionator git-r3
+# By eroen, 2013-2016
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+
+EAPI=6
+
+inherit eutils toolchain-funcs versionator
+if [[ 9999 == $PV ]]; then
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thestinger/termite/archive/v$PV.tar.gz -> $P.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A keyboard-centric VTE-based terminal"
HOMEPAGE="https://github.com/thestinger/termite"
-EGIT_REPO_URI="git://github.com/thestinger/termite.git"
-if [[ ${PV} != 999? ]]; then
- EGIT_COMMIT=v${PV}
-fi
+EGIT_REPO_URI="git://github.com/thestinger/termite.git
+ http://github.com/thestinger/termite.git
+ https://github.com/thestinger/termite.git"
LICENSE="LGPL-2+ MIT"
SLOT="0"
-KEYWORDS=""
IUSE=""
-HDEPEND=""
LIBDEPEND=">=x11-libs/gtk+-3.0
>=x11-libs/vte-0.38:2.91[termite-patch(-)]
"
DEPEND="${LIBDEPEND}"
RDEPEND="${LIBDEPEND}"
-[[ ${EAPI} == *-hdepend ]] || DEPEND+=" ${HDEPEND}"
pkg_pretend() {
if ! version_is_at_least 4.7 $(gcc-version); then
@@ -50,5 +53,5 @@ src_install() {
pkg_postinst() {
elog
elog "Termite looks for a config file ~/.config/termite/config"
- elog "An example config can be found in ${ROOT}usr/share/doc/${PF}/"
+ elog "An example config can be found in ${EROOT}usr/share/doc/${PF}/"
}