summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen-overlay@occam.eroen.eu>2017-07-25 01:11:38 +0200
committereroen <eroen-overlay@occam.eroen.eu>2017-07-25 01:12:00 +0200
commit477c601181374e8d695d22b3f32fa9781f4915b4 (patch)
tree2f089b397a0d9e3a88452401caa3700ae756e0dc
parentvobject-0.9.5 - bump (diff)
downloaderoen-477c601181374e8d695d22b3f32fa9781f4915b4.tar.gz
eroen-477c601181374e8d695d22b3f32fa9781f4915b4.tar.bz2
eroen-477c601181374e8d695d22b3f32fa9781f4915b4.zip
dev-python/pytest-isort from gentoo
-rw-r--r--dev-python/pytest-isort/Manifest1
-rw-r--r--dev-python/pytest-isort/metadata.xml8
-rw-r--r--dev-python/pytest-isort/pytest-isort-0.1.0.ebuild26
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-isort/Manifest b/dev-python/pytest-isort/Manifest
new file mode 100644
index 0000000..620919e
--- /dev/null
+++ b/dev-python/pytest-isort/Manifest
@@ -0,0 +1 @@
+DIST pytest-isort-0.1.0.tar.gz 5502 SHA256 e92798127e21d22513c62070989f0fb3b712650e48a4db13e5b8e8034d367cfe SHA512 86c964b6a998a32c9c474dde0a9400c45da8b26f3e8dd6f4092baa4bf1978a7f67a384bd910ec824f85a8ab49b4ea30967e1e7f908a31619ee88391d3505440b WHIRLPOOL 2cf95b1586ee52ee0f8df44a4a9a6e1ae06fd75dcbc572eab1b7c773c4632f23f5f3e11347c32b9aa67258b433670205dd5102e29d2b6886e94452db9c9e931d
diff --git a/dev-python/pytest-isort/metadata.xml b/dev-python/pytest-isort/metadata.xml
new file mode 100644
index 0000000..32e0609
--- /dev/null
+++ b/dev-python/pytest-isort/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-isort</remote-id>
+ <remote-id type="github">moccu/pytest-isort</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
new file mode 100644
index 0000000..d0c9bc0
--- /dev/null
+++ b/dev-python/pytest-isort/pytest-isort-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for isort"
+HOMEPAGE="https://github.com/moccu/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/isort-3.9.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cache-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"