aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2016-03-02 19:57:54 +0100
committerNicholas Fish <gentoo@seaofdirac.net>2016-03-02 19:57:54 +0100
commit7dff8f036c6de13a6a0a66628bc22f5f42c9fcb4 (patch)
tree9f40a52340e27eb2423186406da5b5967cd72a9f /net-libs
parentAdd qtnetwork ebuild with proper LibreSSL dependencies (diff)
downloadennui-7dff8f036c6de13a6a0a66628bc22f5f42c9fcb4.tar.gz
ennui-7dff8f036c6de13a6a0a66628bc22f5f42c9fcb4.tar.bz2
ennui-7dff8f036c6de13a6a0a66628bc22f5f42c9fcb4.zip
Add LibreSSL-compatible rb_libtorrent ebuild
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/Manifest3
-rw-r--r--net-libs/rb_libtorrent/metadata.xml13
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-1.0.8.ebuild112
3 files changed, 128 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/Manifest b/net-libs/rb_libtorrent/Manifest
new file mode 100644
index 0000000..efee0c0
--- /dev/null
+++ b/net-libs/rb_libtorrent/Manifest
@@ -0,0 +1,3 @@
+DIST rb_libtorrent-1.0.8.tar.gz 2977324 SHA256 24498625d946b80b2269789fb666196240fe805a0b6417d83d1f4dd9ee5f9a7a SHA512 7ab98712225e19224c969fe4c6cd2f21f0aff3f5130dc1b3a0ea1b339b23b3cd303e76aeec9ac23e253c77865c60fd6623f7c8cd4e336c5a16fdf3d4627b88e2 WHIRLPOOL 23c3f84f304e642c7c25239a8a209d37afde41454f8688ef1b24c680d0d268e9163244dc06b973a49a8173f7e1cd7b7bf4f359fb89294cee5868060a64dbb2eb
+EBUILD rb_libtorrent-1.0.8.ebuild 2489 SHA256 990f1ef706ecb18718f5665fae4f6726b9c0185ae4f9fb4abf9b818e59ec2c12 SHA512 d265f0a9304a0bba1b17bca7b13d2a0456ab888cf88e34b828c7b76abd631e54ee4cc070d720060a7484f97761e9cef6a00352055ddf76791e6c7b345f263dc8 WHIRLPOOL ec021511fe686a2beb64d68bdb8f86573da68b8dce09ea4a1094fec64649cfec15a4e7a02894b94034cb4a016feb7d838815c4163fe2c52ad10aa5944f2bf25f
+MISC metadata.xml 456 SHA256 1daede0b12f2a7fe301c1132f5030f5ea6880069baacd35209b4b9cf4b09b858 SHA512 13e4d80c61b0f3c52d2353cb47512a6f6861e81804d7cc1a49c2db7acb2fe12028b3364843429237fceb91e12a6c1575c3d5199c01ef600644532065fc983bcd WHIRLPOOL 8ffc672aadc78475ca29f11874b6caacc967d0d8e17dba42df192b55c78666d514abd3de13c6ef0a83ddcdc5d0c0a9a882543913312b96900467cb4fe9fcefd3
diff --git a/net-libs/rb_libtorrent/metadata.xml b/net-libs/rb_libtorrent/metadata.xml
new file mode 100644
index 0000000..c0cbcd2
--- /dev/null
+++ b/net-libs/rb_libtorrent/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">libtorrent</remote-id>
+ <remote-id type="sourceforge">libtorrent</remote-id>
+ <remote-id type="github">arvidn/libtorrent</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-1.0.8.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-1.0.8.ebuild
new file mode 100644
index 0000000..5c0acd4
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-1.0.8.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib distutils-r1 versionator
+
+MY_PV=$(replace_all_version_separators '_' )
+S=${WORKDIR}/libtorrent-libtorrent-${MY_PV}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/archive/libtorrent-${MY_PV}.tar.gz -> rb_libtorrent-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples libressl python ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/boost-1.53:=[threads]
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl ) )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2"
+
+RESTRICT="test"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ chmod a-x docs/*.rst docs/*.htm* src/*.cpp include/libtorrent/*.hpp || die
+ ./autotool.sh
+}
+
+src_configure() {
+ if use python_targets_python3_3 ;then
+ boost_py3="--with-boost-python=3.3"
+ elif use python_targets_python3_4 ;then
+ boost_py3="--with-boost-python=3.4"
+ elif use python_targets_python3_5 ;then
+ boost_py3="--with-boost-python=3.5"
+ else
+ boost_py3=""
+ fi
+
+ if use python_targets_python2_7 ;then
+ boost_py2="--with-boost-python=2.7"
+ else
+ boost_py2=""
+ fi
+
+ local myeconfargs=(
+ --disable-silent-rules # bug 441842
+ --with-boost-system=mt
+ $(use_enable debug)
+ $(use_enable test tests)
+ $(use_enable examples)
+ $(use_enable ssl encryption)
+ $(use_enable python python-binding)
+ $(usex debug "--enable-logging=verbose" "")
+ ${boost_py3}
+ ${boost_py2}
+ )
+
+ if use python ;then
+ python_setup
+ fi
+
+ autotools-utils_src_configure
+
+ if use python ;then
+ cd "${BUILD_DIR}"/bindings/python || die && \
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python ;then
+ cd "${BUILD_DIR}"/bindings/python || die && \
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ if use doc ;then
+ HTML_DOCS=( "${S}"/docs/. )
+ fi
+
+ autotools-utils_src_install
+
+ if use python ;then
+ cd "${BUILD_DIR}"/bindings/python || die && \
+ distutils-r1_src_install
+ fi
+}